aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-07-04 16:55:16 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-07-04 16:55:16 +0000
commitbe86c4fe23e089aeef1ed7467161c2ce321a8c81 (patch)
treeeebf8f5b9a2bc359ffda39b2eac6fa88f6345545 /Mk
parent066b4db9b1ddaadd5fb0c7076733998f810dcda8 (diff)
downloadports-be86c4fe23e089aeef1ed7467161c2ce321a8c81.tar.gz
ports-be86c4fe23e089aeef1ed7467161c2ce321a8c81.zip
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/qt-dist.mk19
-rw-r--r--Mk/Uses/qt.mk7
2 files changed, 9 insertions, 17 deletions
diff --git a/Mk/Uses/qt-dist.mk b/Mk/Uses/qt-dist.mk
index 19ee4b66c4ab..df834b215985 100644
--- a/Mk/Uses/qt-dist.mk
+++ b/Mk/Uses/qt-dist.mk
@@ -172,7 +172,7 @@ _EXTRA_PATCHES_QT5= ${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_fe
${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_features_qt__module.prf \
${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_common_bsd_bsd.conf \
${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_freebsd-clang_qmake.conf
-. if ${ARCH:Mmips*} || (${ARCH:Mpowerpc*} && !exists(/usr/bin/clang)) || ${ARCH} == sparc64
+. if ${ARCH:Mmips*} || (${ARCH:Mpowerpc*} && !exists(/usr/bin/clang)) || ${ARCH} == sparc64
_EXTRA_PATCHES_QT5+= ${PORTSDIR}/devel/${_QT_RELNAME}/files/extra-patch-mkspecs_common_g++-base.conf \
${PORTSDIR}/devel/${_QT_RELNAME}/files/extra-patch-mkspecs_common_gcc-base.conf \
${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_freebsd-g++_qmake.conf
@@ -204,15 +204,6 @@ QMAKE_ARGS+= QT_CONFIG+="${QT_CONFIG:N-*:O:u}"
QMAKE_ARGS+= QT_CONFIG-="${QT_CONFIG:M-*:O:u:C/^-//}"
. endif
-# Add a RUN_DEPENDS on misc/qtchooser to select the binaries.
-# The binaries of both supported Qt versions are installed to
-# ${LOCALBASE}/lib/qt${_QT_VER}/bin. The port misc/qtchooser installs
-# wrapper binaries into ${LOCALBASE}/bin, and chooses the correct
-# one depending on the value of QT_SELECT (which we pass to both
-# CONFIGURE_ENV and MAKE_ENV). Therefore make all QT_DIST ports
-# RUN_DEPEND on it.
-RUN_DEPENDS+= qtchooser:misc/qtchooser
-
PLIST_SUB+= SHORTVER=${DISTVERSION:R} \
FULLVER=${DISTVERSION:C/-.*//}
@@ -248,7 +239,7 @@ _QT_TOOLS+= ${UIC}
_QT5_BASE= core dbus gui network sql widgets
_QT5_ADDITIONAL_LINK?= # Ensure definition
-.if ${_QT_VER:M5}
+. if ${_QT_VER:M5}
post-patch: gcc-post-patch
gcc-post-patch:
${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|g' \
@@ -259,7 +250,7 @@ gcc-post-patch:
${WRKSRC}/mkspecs/common/g++-base.conf \
${WRKSRC}/mkspecs/common/bsd/bsd.conf \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
-.endif
+. endif
pre-configure: qtbase-pre-configure
qtbase-pre-configure:
@@ -353,11 +344,9 @@ _sub_need_remove= \#\#
_sub_need_add= \#\#
_sub_need_remove=
. endif
-# Handle misc/qtchooser wrapper installation and deinstallation
# If a port installs Qt version-specific binaries (e.g. "designer" which
# existed as a Qt4 application and exists as a Qt5 application and will
-# probably be a Qt6 application) which should have a qtchooser-based wrapper,
-# the port should set `QT_BINARIES=yes`.
+# probably be a Qt6 application) the port should set `QT_BINARIES=yes`.
. if defined(QT_BINARIES)
_sub_need_bin=
. else
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index 8479ed2b0c13..932d1fd4cd0e 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -70,18 +70,21 @@ QT_ETCDIR_REL?= etc/xdg
QT_EXAMPLEDIR_REL?= share/examples/${_QT_RELNAME}
QT_TESTDIR_REL?= ${QT_DATADIR_REL}/tests
QT_CMAKEDIR_REL?= lib/cmake
-QT_QTCHOOSERDIR_REL?= ${QT_ETCDIR_REL}/qtchooser
# Not customizable.
QT_MKSPECDIR_REL= ${QT_ARCHDIR_REL}/mkspecs
_QT_LIBVER= ${_QT_VERSION:R:R}
+LCONVERT?= ${QT_BINDIR}/lconvert
LRELEASE?= ${QT_BINDIR}/lrelease
LUPDATE?= ${QT_BINDIR}/lupdate
MOC?= ${QT_BINDIR}/moc
RCC?= ${QT_BINDIR}/rcc
UIC?= ${QT_BINDIR}/uic
QMAKE?= ${QT_BINDIR}/qmake
+QCOLLECTIONGENERATOR?= ${QT_BINDIR}/qcollectiongenerator
+QHELPGENERATOR?= ${QT_BINDIR}/qhelpgenerator
+
# Needed to redefine the qmake target for internal Qt configuration.
_QMAKE?= ${QMAKE}
QMAKESPECNAME?= freebsd-${QMAKE_COMPILER}
@@ -95,7 +98,7 @@ QMAKE_COMPILER= $$(ccver="$$(${CXX} --version)"; case "$$ccver" in *clang*) echo
. for dir in BIN INC LIB ARCH PLUGIN LIBEXEC IMPORT \
QML DATA DOC L10N ETC EXAMPLE TEST MKSPEC \
- CMAKE QTCHOOSER
+ CMAKE
QT_${dir}DIR= ${PREFIX}/${QT_${dir}DIR_REL}
# Export all directories to the plist substituion for QT_DIST ports.
# For the others, exclude QT_CMAKEDIR and QT_ETCDIR.