aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-29 16:19:55 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-29 16:19:55 +0000
commite109535adfb36c36bac15838ed278e5fe65900ed (patch)
tree15d2b0e0d3ff433c402761f651885d7fb60132aa /Mk
parent0ab603561a41ee29cd18ef16157acbaee679e100 (diff)
downloadports-e109535adfb36c36bac15838ed278e5fe65900ed.tar.gz
ports-e109535adfb36c36bac15838ed278e5fe65900ed.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.options.mk16
1 files changed, 4 insertions, 12 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index f4581ae13710..0a11a7e68078 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -499,14 +499,10 @@ ${_u:tu}= ${${opt}_VARS:M${var}=*:C/[^=]*=//:C/^"(.*)"$$/\1/}
. endfor
. endif
. if defined(${opt}_CONFIGURE_ENABLE)
-. for iopt in ${${opt}_CONFIGURE_ENABLE}
-CONFIGURE_ARGS+= --enable-${iopt}
-. endfor
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ENABLE:C/^/--enable-/}
. endif
. if defined(${opt}_CONFIGURE_WITH)
-. for iopt in ${${opt}_CONFIGURE_WITH}
-CONFIGURE_ARGS+= --with-${iopt}
-. endfor
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_WITH:C/^/--with-/}
. endif
. for configure in CONFIGURE CMAKE QMAKE
. if defined(${opt}_${configure}_ON)
@@ -547,14 +543,10 @@ ${_u:tu}= ${${opt}_VARS_OFF:M${var}=*:C/[^=]*=//:C/^"(.*)"$$/\1/}
. endfor
. endif
. if defined(${opt}_CONFIGURE_ENABLE)
-. for iopt in ${${opt}_CONFIGURE_ENABLE}
-CONFIGURE_ARGS+= --disable-${iopt:C/=.*//}
-. endfor
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ENABLE:S/^/--disable-/:C/=.*//}
. endif
. if defined(${opt}_CONFIGURE_WITH)
-. for iopt in ${${opt}_CONFIGURE_WITH}
-CONFIGURE_ARGS+= --without-${iopt:C/=.*//}
-. endfor
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_WITH:C/^/--without-/:C/=.*//}
. endif
. for configure in CONFIGURE CMAKE QMAKE
. if defined(${opt}_${configure}_OFF)