aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-01-26 03:58:58 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-01-26 03:58:58 +0000
commit047e50052820f8d50471a8d506030e60ed431598 (patch)
tree628bdcb98088bcffbc93de193810655ceba78254 /Mk
parentec9c4b65b864b025f4b2b4447f0f5732a61f51af (diff)
downloadports-047e50052820f8d50471a8d506030e60ed431598.tar.gz
ports-047e50052820f8d50471a8d506030e60ed431598.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk21
1 files changed, 10 insertions, 11 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1b6428627223..ee98ea25217e 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
#-*- mode: Fundamental; tab-width: 4; -*-
# ex:ts=4
#
-# $Id: bsd.port.mk,v 1.301 1999/01/11 13:04:18 asami Exp $
+# $Id: bsd.port.mk,v 1.302 1999/01/20 01:55:05 asami Exp $
# $NetBSD: $
#
# bsd.port.mk - 940820 Jordan K. Hubbard.
@@ -458,7 +458,7 @@ DISTDIR?= ${PORTSDIR}/distfiles
_DISTDIR?= ${DISTDIR}/${DIST_SUBDIR}
EXTRACT_SUFX?= .tar.gz
PACKAGES?= ${PORTSDIR}/packages
-TEMPLATES?= ${PORTSDIR}/templates
+TEMPLATES?= ${PORTSDIR}/Templates
.if exists(${MASTERDIR}/patches.${ARCH}-${OPSYS})
PATCHDIR?= ${MASTERDIR}/patches.${ARCH}-${OPSYS}
@@ -854,24 +854,23 @@ PATCH_SITES:= ${PATCH_SITES:S/%SUBDIR%/${PATCH_SITE_SUBDIR}/}
MASTER_SITE_BACKUP?= \
ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/${DIST_SUBDIR}/
-# If the user has this set, go to the FreeBSD repository for everything.
-.if defined(MASTER_SITE_FREEBSD)
-MASTER_SITE_OVERRIDE= ${MASTER_SITE_BACKUP}
-.endif
-
# Where to put distfiles that don't have any other master site
MASTER_SITE_LOCAL?= \
ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/LOCAL_PORTS/
-# I guess we're in the master distribution business! :) As we gain mirror
-# sites for distfiles, add them to this list.
-.if !defined(MASTER_SITE_OVERRIDE)
+# If the user has MASTER_SITE_FREEBSD set, go to the FreeBSD repository
+# for everything, but don't search it twice by appending it to the end.
+.if !defined(MASTER_SITE_FREEBSD)
MASTER_SITES+= ${MASTER_SITE_BACKUP}
PATCH_SITES+= ${MASTER_SITE_BACKUP}
-.else
+.if defined(MASTER_SITE_OVERRIDE)
MASTER_SITES:= ${MASTER_SITE_OVERRIDE} ${MASTER_SITES}
PATCH_SITES:= ${MASTER_SITE_OVERRIDE} ${PATCH_SITES}
.endif
+.else
+MASTER_SITES:= ${MASTER_SITE_BACKUP} ${MASTER_SITES}
+PATCH_SITES:= ${MASTER_SITE_BACKUP} ${MASTER_SITES}
+.endif
# Search CDROM first if mounted, symlink instead of copy if
# FETCH_SYMLINK_DISTFILES is set