aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-11-30 12:54:55 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-12-05 12:35:41 +0000
commit237b36fa2e73986dc19284686e80a47cb329bb6f (patch)
treeabc3279705b006763706536c7330abed816a4690 /Mk
parentca42ce1e88303283ca74cbea21f224d6d45f0f6b (diff)
downloadports-237b36fa2e73986dc19284686e80a47cb329bb6f.tar.gz
ports-237b36fa2e73986dc19284686e80a47cb329bb6f.zip
lang/rust: Update to 1.57.0
- Unbreak build with LibreSSL 3.4.x [0] - Disable backtrace's libunwind backend on armv* since it or libunwind in base seem to be buggy and cause rustc to crash when building some consumers [1] - Follow rust-nightly in d5f09dc31fcfdb77b69c86b9093bf67ec67653d9 and reenable hardlinks in the build Changes: https://blog.rust-lang.org/2021/12/02/Rust-1.57.0.html PR: 259738 [0] PR: 259799 [1] PR: 260140 Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D33190 With hat: rust
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cargo.mk2
-rw-r--r--Mk/bsd.gecko.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index 89e0d0704013..1636f2da320f 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -97,7 +97,7 @@ WRKSRC_crate_${_crate}= ${WRKDIR}/${_wrksrc}
CARGO_BUILDDEP?= yes
.if ${CARGO_BUILDDEP:tl} == "yes"
-BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.56.0:lang/${RUST_DEFAULT}
+BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.57.0:lang/${RUST_DEFAULT}
.endif
# Location of toolchain (default to lang/rust's toolchain)
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index b4500564c0ce..e875a09d7244 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -76,7 +76,7 @@ BUNDLE_LIBS= yes
BUILD_DEPENDS+= llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT} \
rust-cbindgen>=0.19.0:devel/rust-cbindgen \
- ${RUST_DEFAULT}>=1.56.0:lang/${RUST_DEFAULT} \
+ ${RUST_DEFAULT}>=1.57.0:lang/${RUST_DEFAULT} \
node:www/node
LIB_DEPENDS+= libdrm.so:graphics/libdrm
RUN_DEPENDS+= ${LOCALBASE}/lib/libpci.so:devel/libpci