aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-11-30 18:22:07 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-11-30 18:22:07 +0000
commitdcc6b13daedf095da6572c27af69713ee551cb81 (patch)
treee9e3967a30b72780cc01f97a43b0d38d36099b03 /Mk
parent0741c12be4feae09104b54241a08d9db2d30567f (diff)
downloadports-dcc6b13daedf095da6572c27af69713ee551cb81.tar.gz
ports-dcc6b13daedf095da6572c27af69713ee551cb81.zip
www/firefox: make dep on wasi-compiler-rt more flexible
as firefox needs matching wasi-compiler-rt, embedded llvm in rust and llvm for building and wasi-compiler-rt installs it's files in a path depending on it's full distversion, we need to know llvm/clang's full version. it's not possible to derive that programatically, as the required llvm version may not be installed at the time firefox' Makefile is being parsed.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index b912e1aa7ade..b4500564c0ce 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -95,6 +95,7 @@ MOZ_EXPORT+= LLVM_OBJDUMP="${LOCALBASE}/bin/llvm-objdump${LLVM_DEFAULT}"
# Ignore Mk/bsd.default-versions.mk but respect make.conf(5) unless LTO is enabled
.if !defined(DEFAULT_VERSIONS) || ! ${DEFAULT_VERSIONS:Mllvm*} || ${PORT_OPTIONS:MLTO}
LLVM_DEFAULT= 13 # chase bundled LLVM in lang/rust for LTO
+LLVM_VERSION= 13.0.0 # keep in sync with devel/wasi-compiler-rt${LLVM_DEFAULT}
.endif
# Require newer Clang than what's in base system unless user opted out
. if ${CC} == cc && ${CXX} == c++ && exists(/usr/lib/libc++.so)