aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-04-11 07:53:19 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-04-11 07:53:19 +0000
commit2288ee2ec6af401765f502f3c1f335b7914315f4 (patch)
treef3fbeaccc0b8deee60a876f8d893eba5064178e6 /Mk
parent40fbdcdd73ca8833c31a8316619a7feaf7758ace (diff)
downloadports-2288ee2ec6af401765f502f3c1f335b7914315f4.tar.gz
ports-2288ee2ec6af401765f502f3c1f335b7914315f4.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.php.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index f62f60352cff..19b96f47f249 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -41,6 +41,7 @@ PHPBASE?= ${LOCALBASE}
.if exists(${PHPBASE}/etc/php.conf)
.include "${PHPBASE}/etc/php.conf"
PHP_EXT_DIR!= ${PHPBASE}/bin/php-config --extension-dir | ${SED} -ne 's,^${PHPBASE}/lib/php/\(.*\),\1,p'
+# The following block should be eventually removed from here or php5 port
.if ${PHP_VER} == 5
PHP_EXT_INC= pcre spl
.endif
@@ -250,7 +251,7 @@ _USE_PHP_ALL= apc bcmath bitset bz2 calendar ctype curl dba \
# version specific components
_USE_PHP_VER4= ${_USE_PHP_ALL} crack dbase dbx dio domxml filepro mcal mcve \
mhash ncurses oracle overload pfpro xslt yp
-_USE_PHP_VER5= ${_USE_PHP_ALL} dom filter mysqli oci8 pdo \
+_USE_PHP_VER5= ${_USE_PHP_ALL} dom filter mysqli pdo \
pdo_mysql pdo_pgsql pdo_sqlite \
simplexml soap spl sqlite tidy xmlreader xmlwriter xsl
@@ -291,7 +292,6 @@ mssql_DEPENDS= databases/php${PHP_VER}-mssql
mysql_DEPENDS= databases/php${PHP_VER}-mysql
mysqli_DEPENDS= databases/php${PHP_VER}-mysqli
ncurses_DEPENDS=devel/php${PHP_VER}-ncurses
-oci8_DEPENDS= databases/php${PHP_VER}-oci8
odbc_DEPENDS= databases/php${PHP_VER}-odbc
openssl_DEPENDS=security/php${PHP_VER}-openssl
oracle_DEPENDS= databases/php${PHP_VER}-oracle