aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-03-18 13:36:57 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-03-22 12:29:52 +0000
commit306567bc74fbdfb30c62479083b933835f314c8f (patch)
tree6f5b8c9a61a54524ad5661e2cd17bfd0481a8daf /Mk
parent52598b84ea0eb90860dcf06d781883cd8fe187fe (diff)
downloadports-306567bc74fbdfb30c62479083b933835f314c8f.tar.gz
ports-306567bc74fbdfb30c62479083b933835f314c8f.zip
x11-fonts/fontconfig: Use triggers to rebuild fc-cache
Stop forcing the overwrite of the cache at each run it is not necessary most of the time. Reviewed by: tcberner Differencial Revision: https://reviews.freebsd.org/D34602 While here rework USES=fonts to drop @fcfontsdir which is not nessary anymore and convert the @fontsdir into lua which make it way simpler to read
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/fonts.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/Mk/Uses/fonts.mk b/Mk/Uses/fonts.mk
index acc751b5be2f..1547744747bc 100644
--- a/Mk/Uses/fonts.mk
+++ b/Mk/Uses/fonts.mk
@@ -41,23 +41,23 @@
_INCLUDE_USES_FONTS_MK= yes
.if empty(fonts_ARGS)
-fonts_ARGS= fcfontsdir
+fonts_ARGS= fontsdir
.endif
-.if !empty(fonts_ARGS:Nfc:Nfontsdir:Nfcfontsdir:Nnone)
+.if !empty(fonts_ARGS:Nfc:Nfontsdir:Nnone)
IGNORE= USES=fonts - invalid ARGS (${fonts_ARGS})
.endif
-.if !empty(fonts_ARGS:Mfc) || !empty(fonts_ARGS:Mfcfontsdir)
+.if !empty(fonts_ARGS:Mfc) || !empty(fonts_ARGS:Mfontsdir)
RUN_DEPENDS+= fc-cache:x11-fonts/fontconfig
.endif
-.if !empty(fonts_ARGS:Mfontsdir) || !empty(fonts_ARGS:Mfcfontsdir)
+.if !empty(fonts_ARGS:Mfontsdir)
RUN_DEPENDS+= mkfontscale:x11-fonts/mkfontscale
.endif
FONTNAME?= ${PORTNAME}
FONTSDIR?= ${PREFIX}/share/fonts/${FONTNAME}
-.if !empty(fonts_ARGS:Nnone)
+.if !empty(fonts_ARGS:Mfontsdir)
PLIST_FILES+= "@${fonts_ARGS} ${FONTSDIR}"
.endif
.if defined(FONTPATHSPEC) && !empty(FONTPATHSPEC)