aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2018-09-11 18:52:07 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2018-09-11 18:52:07 +0000
commit3aec45228ffdfe1a3e6435072997631bc1e10e52 (patch)
tree8e6a107592524edf4c25a09fbfe0a05a6df68bd8 /Mk
parent775bd023f31a2d815af7e4f7325b408cf9331a9e (diff)
downloadports-3aec45228ffdfe1a3e6435072997631bc1e10e52.tar.gz
ports-3aec45228ffdfe1a3e6435072997631bc1e10e52.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gl.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/Uses/gl.mk b/Mk/Uses/gl.mk
index bced5b41c55e..4d34c045c977 100644
--- a/Mk/Uses/gl.mk
+++ b/Mk/Uses/gl.mk
@@ -4,7 +4,7 @@
#
# Feature: gl
# Usage: USES=gl
-# USE_GL=egl glesv2 glut glu glw gl
+# USE_GL=egl gbm gl glesv2 glew glu glut glw
#
# USE_GL specifies which GL components to add as dependencies.
# Not specifying USE_GL with USES=gl is an error.
@@ -15,16 +15,16 @@
.if !defined(_INCLUDE_USES_GL_MK)
_INCLUDE_USES_GL_MK=yes
-_GL_gbm_LIB_DEPENDS= libgbm.so:graphics/mesa-libs
-_GL_glesv2_LIB_DEPENDS= libGLESv2.so:graphics/mesa-libs
_GL_egl_LIB_DEPENDS= libEGL.so:graphics/mesa-libs
+_GL_gbm_LIB_DEPENDS= libgbm.so:graphics/mesa-libs
_GL_gl_LIB_DEPENDS= libGL.so:graphics/mesa-libs
_GL_gl_USE_XORG= xorgproto
+_GL_glesv2_LIB_DEPENDS= libGLESv2.so:graphics/mesa-libs
_GL_glew_LIB_DEPENDS= libGLEW.so:graphics/glew
_GL_glu_LIB_DEPENDS= libGLU.so:graphics/libGLU
_GL_glu_USE_XORG= xorgproto
-_GL_glw_LIB_DEPENDS= libGLw.so:graphics/libGLw
_GL_glut_LIB_DEPENDS= libglut.so:graphics/freeglut
+_GL_glw_LIB_DEPENDS= libGLw.so:graphics/libGLw
.if !empty(gl_ARGS)
IGNORE= USES=gl takes no arguments