aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-09 14:30:02 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-09 14:30:02 +0000
commit7cffd3c8f90872c68664bd0c51b48f9e2c59e611 (patch)
treeca64d90fe979fab8f7ed8d1e9bdd41583f1793d9 /Mk
parent232584a7099c1614b5d83999ae19aa01004d0232 (diff)
downloadports-7cffd3c8f90872c68664bd0c51b48f9e2c59e611.tar.gz
ports-7cffd3c8f90872c68664bd0c51b48f9e2c59e611.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
-rw-r--r--Mk/bsd.sanity.mk4
-rw-r--r--Mk/bsd.sdl.mk31
3 files changed, 6 insertions, 33 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a674863197c2..9068aa560cf6 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1445,7 +1445,7 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.include "${PORTSDIR}/Mk/bsd.gstreamer.mk"
.endif
-.if defined(USE_SDL) || defined(WANT_SDL)
+.if defined(USE_SDL)
.include "${PORTSDIR}/Mk/bsd.sdl.mk"
.endif
@@ -1916,7 +1916,7 @@ _FORCE_POST_PATTERNS= rmdir kldxref mkfontscale mkfontdir fc-cache \
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif
-.if defined(USE_SDL) || defined(WANT_SDL)
+.if defined(USE_SDL)
.include "${PORTSDIR}/Mk/bsd.sdl.mk"
.endif
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index 3a36bf6154fd..fa5e543183f6 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -153,6 +153,10 @@ DEV_WARNING+= "PYDISTUTILS_INSTALLNOSINGLE is deprecated, please do not use it a
DEV_ERROR+= "INSTALLS_EGGINFO is no longer supported, please add the entry directly to the plist"
.endif
+.if defined(WANT_SDL)
+DEV_ERROR+= "WANT_SDL is no longer supported. If you need SDL, use USE_SDL, if you need optional dependency, use options"
+.endif
+
SANITY_UNSUPPORTED= USE_OPENAL USE_FAM USE_MAKESELF USE_ZIP USE_LHA USE_CMAKE \
USE_READLINE USE_ICONV PERL_CONFIGURE PERL_MODBUILD \
USE_PERL5_BUILD USE_PERL5_RUN USE_DISPLAY USE_FUSE \
diff --git a/Mk/bsd.sdl.mk b/Mk/bsd.sdl.mk
index de3bdfb11a63..4e93b8303c5f 100644
--- a/Mk/bsd.sdl.mk
+++ b/Mk/bsd.sdl.mk
@@ -16,17 +16,6 @@
# the standard SDL and SDL_sound, use "USE_SDL=sdl sound" and the
# required libraries are included in your LIB_DEPENDS.
#
-# If you want to check for the availability for certain SDL ports, you
-# can set WANT_SDL and run it through bsd.port.pre.mk:
-# WANT_SDL= yes
-# USE_SDL= sdl
-# .include <bsd.port.pre.mk>
-# .if ${HAVE_SDL:Mgraphics}
-# USE_SDL+= graphics
-# .endif
-# .include <bsd.port.post.mk>
-# Run "make -V USE_SDL" to see which libs are asked for at the end.
-#
#
# $FreeBSD$
@@ -132,26 +121,6 @@ _LIB_ttf2= libSDL2_ttf.so
_REQUIRES_ttf2= sdl2
#
-# If WANT_SDL is defined, check for the available libraries
-#
-.if !defined(AFTERPORTMK)
-.if !defined(SDL_Include_pre)
-
-SDL_Include_pre= bsd.sdl.mk
-
-HAVE_SDL?=
-.if defined(WANT_SDL)
-.for component in ${_USE_SDL_ALL}
-.if exists(${LOCALBASE}/lib/lib${_LIB_${component}}.so)
-HAVE_SDL+= ${component}
-.endif
-.endfor
-.endif
-
-.endif
-.endif
-
-#
# If USE_SDL is defined, make dependencies for the libraries
#
.if !defined(BEFOREPORTMK)