aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-07-19 14:36:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-07-19 14:36:00 +0000
commit81471a0b2a688eaa10b976b1e7028d5bae6a62fe (patch)
treef169cf3f82bb036a610b94fc037cf9a640b24317 /Mk
parent8088e0cda1ff0aa065274972fcfc56c3d90cab3a (diff)
downloadports-81471a0b2a688eaa10b976b1e7028d5bae6a62fe.tar.gz
ports-81471a0b2a688eaa10b976b1e7028d5bae6a62fe.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/libarchive.mk16
-rw-r--r--Mk/Uses/libedit.mk16
-rw-r--r--Mk/Uses/localbase.mk18
3 files changed, 50 insertions, 0 deletions
diff --git a/Mk/Uses/libarchive.mk b/Mk/Uses/libarchive.mk
new file mode 100644
index 000000000000..c2df6b5bbe66
--- /dev/null
+++ b/Mk/Uses/libarchive.mk
@@ -0,0 +1,16 @@
+# $FreeBSD$
+#
+# handle dependency on the libarchive port
+#
+# Feature: libarchive
+# Usage: USES=libarchive
+# Valid ARGS: none
+#
+# MAINTAINER: portmgr@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_LIBARCHIVE_MK)
+_INCLUDE_USES_LIBARCHIVE_MK= yes
+.include "${USESDIR}/localbase.mk"
+
+LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
+.endif
diff --git a/Mk/Uses/libedit.mk b/Mk/Uses/libedit.mk
new file mode 100644
index 000000000000..5eb9f3c20248
--- /dev/null
+++ b/Mk/Uses/libedit.mk
@@ -0,0 +1,16 @@
+# $FreeBSD$
+#
+# handle dependency on the libedit port
+#
+# Feature: libedit
+# Usage: USES=libedit
+# Valid ARGS: none
+#
+# MAINTAINER: portmgr@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_LIBEDIT_MK)
+_INCLUDE_USES_LIBEDIT_MK= yes
+.include "${USESDIR}/localbase.mk"
+
+LIB_DEPENDS+= libedit.so.0:${PORTSDIR}/devel/libedit
+.endif
diff --git a/Mk/Uses/localbase.mk b/Mk/Uses/localbase.mk
new file mode 100644
index 000000000000..044cfcd11faa
--- /dev/null
+++ b/Mk/Uses/localbase.mk
@@ -0,0 +1,18 @@
+# $FreeBSD$
+#
+# handle enforcing localbase in path
+#
+# Feature: localbase
+# Usage: USES=localbase
+# Valid ARGS: none
+#
+# MAINTAINER: portmgr@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_LOCALBASE_MK)
+_INCLUDE_USES_LOCALBASE_MK= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}include
+LDFLAGS+= -L${LOCALBASE}/lib
+.endif