aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-22 13:21:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-22 13:21:29 +0000
commit124b350ddb6cf198d656b1379932ef80a06468b6 (patch)
tree4d47f99ee59aaefafd774da3b2cd4b925abc4389 /Mk
parentfd9d7c95d2aa66d3c3847f57914b5ed0798a91aa (diff)
downloadports-124b350ddb6cf198d656b1379932ef80a06468b6.tar.gz
ports-124b350ddb6cf198d656b1379932ef80a06468b6.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk13
1 files changed, 4 insertions, 9 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 9328d60504bb..201e44755d5f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5229,13 +5229,10 @@ add-plist-info:
.for i in ${INFO}
@${LS} ${STAGEDIR}${PREFIX}/${INFO_PATH}/$i.info* | ${SED} -e s:${STAGEDIR}${PREFIX}/:@info\ :g >> ${TMPPLIST}
.endfor
-.if defined(INFO_SUBDIR)
- @${ECHO_CMD} "@dirrmtry ${INFO_PATH}/${INFO_SUBDIR}" >> ${TMPPLIST}
-.endif
.if (${PREFIX} != "/usr")
@${ECHO_CMD} "@unexec indexinfo %D/${INFO_PATH}" >> ${TMPPLIST}
.if (${PREFIX} != ${LOCALBASE} && ${PREFIX} != ${LINUXBASE})
- @${ECHO_CMD} "@dirrmtry ${INFO_PATH}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@dir ${INFO_PATH}" >> ${TMPPLIST}
.endif
.endif
.endif
@@ -5247,7 +5244,7 @@ add-plist-info:
.if (${PREFIX} != ${LOCALBASE} && ${PREFIX} != ${LINUXBASE} && \
${PREFIX} != "/usr" && !defined(NO_PREFIX_RMDIR))
add-plist-post:
- @${ECHO_CMD} "@dirrmtry ${PREFIX}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@dir ${PREFIX}" >> ${TMPPLIST}
.endif
.endif
@@ -6001,9 +5998,8 @@ _STAGE_SEQ= stage-message stage-dir run-depends lib-depends apply-slist pre-ins
pre-su-install
.if defined(NEED_ROOT)
_STAGE_SUSEQ= create-users-groups do-install \
- kmod-post-install shared-mime-post-install \
+ kmod-post-install \
webplugin-post-install post-install post-install-script \
- desktop-file-post-install \
move-uniquefiles patch-lafiles post-stage compress-man \
install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs \
@@ -6014,9 +6010,8 @@ _STAGE_SUSEQ+= stage-qa
.endif
.else
_STAGE_SEQ+= create-users-groups do-install \
- kmod-post-install shared-mime-post-install \
+ kmod-post-install \
webplugin-post-install post-install post-install-script \
- desktop-file-post-install \
move-uniquefiles patch-lafiles post-stage compress-man \
install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs \