aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2009-03-04 15:54:29 +0000
committerAlex Dupre <ale@FreeBSD.org>2009-03-04 15:54:29 +0000
commit2138a63f9092c8fb8216f4c8b363659f2ba18f21 (patch)
treebe008c5ed16cd57625e5515980fdce9211c1b352 /Mk
parentc8f7cc4d4d47c0c289661fe159f401acc8a2c938 (diff)
downloadports-2138a63f9092c8fb8216f4c8b363659f2ba18f21.tar.gz
ports-2138a63f9092c8fb8216f4c8b363659f2ba18f21.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.database.mk17
1 files changed, 12 insertions, 5 deletions
diff --git a/Mk/bsd.database.mk b/Mk/bsd.database.mk
index 37a530be5213..57cbbd92843b 100644
--- a/Mk/bsd.database.mk
+++ b/Mk/bsd.database.mk
@@ -15,7 +15,7 @@ Database_Include_MAINTAINER= ports@FreeBSD.org
# or WANT_[DATABSE]_VER will include this file too.
#
##
-# USE_MYSQL - Add MySQL client dependency.
+# USE_MYSQL - Add MySQL (client/server/embedded) dependency. (default: client)
# If no version is given (by the maintainer via the port or
# by the user via defined variable), try to find the
# currently installed version. Fall back to default if
@@ -130,12 +130,12 @@ IGNORE= cannot install: MySQL versions mismatch: mysql${_MYSQL_VER}-client is in
.endif
.endif
+.if (${USE_MYSQL} == "embedded")
+IGNORE_WITH_MYSQL= 323 40 41
+.endif
+
# And now we are checking if we can use it
.if defined(MYSQL${MYSQL_VER}_LIBVER)
-# compatability shim
-.if defined(BROKEN_WITH_MYSQL)
-IGNORE_WITH_MYSQL=${BROKEN_WITH_MYSQL}
-.endif
.if defined(IGNORE_WITH_MYSQL)
. for VER in ${IGNORE_WITH_MYSQL}
. if (${MYSQL_VER} == "${VER}")
@@ -143,7 +143,14 @@ IGNORE= cannot install: doesn't work with MySQL version : ${MYSQL_VER} (Doesn't
. endif
. endfor
.endif # IGNORE_WITH_MYSQL
+.if (${USE_MYSQL} == "server" || ${USE_MYSQL} == "embedded")
+RUN_DEPENDS+= ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
+.if (${USE_MYSQL} == "embedded")
+BUILD_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqld.a:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
+.endif
+.else
LIB_DEPENDS+= mysqlclient.${MYSQL${MYSQL_VER}_LIBVER}:${PORTSDIR}/databases/mysql${MYSQL_VER}-client
+.endif
.else
IGNORE= cannot install: unknown MySQL version: ${MYSQL_VER}
.endif # Check for correct libs