aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-02-25 10:55:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-02-25 10:55:08 +0000
commit996d853fd467b7271038f6cd1b11ceac26b20f22 (patch)
treee9dbf6be032848547dbc699695cb1c4d714ecca4 /Mk
parent137587880ddc61faa5afe69044192b6d1d76f622 (diff)
downloadports-996d853fd467b7271038f6cd1b11ceac26b20f22.tar.gz
ports-996d853fd467b7271038f6cd1b11ceac26b20f22.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 2 insertions, 12 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1499103d309b..1381e53997c0 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -871,14 +871,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# change the owner and group of all files under ${WRKDIR}
# to 0:0. Set this variable if you want to turn off this
# feature.
-#
-# For makesum:
-#
-# NO_SIZE - Don't record size data in distinfo, needed
-# when the master site does not report file
-# sizes, or when multiple valid versions of
-# a distfile, having different sizes, exist.
-#
# For patch:
#
# EXTRA_PATCHES - Define this variable if you have patches not in
@@ -1229,7 +1221,7 @@ OSREL!= ${UNAME} -r | ${SED} -e 's/[-(].*//'
.if exists(/usr/include/sys/param.h)
OSVERSION!= ${AWK} '/^\#define[[:blank:]]__FreeBSD_version/ {print $$3}' < /usr/include/sys/param.h
.elif exists(/usr/src/sys/sys/param.h)
-OSVERSION!= ${AWK} '/^\#define[[:blank::]]__FreeBSD_version/ {print $$3}' < /usr/src/sys/sys/param.h
+OSVERSION!= ${AWK} '/^\#define[[:blank:]]__FreeBSD_version/ {print $$3}' < /usr/src/sys/sys/param.h
.else
OSVERSION!= ${SYSCTL} -n kern.osreldate
.endif
@@ -4930,9 +4922,7 @@ makesum: check-checksum-algorithms
$$alg_executable $$file >> ${DISTINFO_FILE}; \
fi; \
done; \
- if [ -z "${NO_SIZE}" ]; then \
- ${ECHO_CMD} "SIZE ($$file) = "`${LS} -ALln $$file | ${AWK} '{print $$5}'` >> ${DISTINFO_FILE}; \
- fi; \
+ ${ECHO_CMD} "SIZE ($$file) = "`${LS} -ALln $$file | ${AWK} '{print $$5}'` >> ${DISTINFO_FILE}; \
done \
)
@for file in ${_IGNOREFILES}; do \