aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-07-16 06:05:59 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-07-16 06:05:59 +0000
commitef0a0c91f153782cd38b84d14147dfa8cef8337f (patch)
treecaa550e9c6de6d456de3b7c58dd8a734b5352b71 /Mk
parent0f6380feb102214049ed4d6947dbd85a02b35d19 (diff)
downloadports-ef0a0c91f153782cd38b84d14147dfa8cef8337f.tar.gz
ports-ef0a0c91f153782cd38b84d14147dfa8cef8337f.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gecko.mk12
-rw-r--r--Mk/bsd.gecko.mk4
2 files changed, 8 insertions, 8 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index eabf5167f67f..45af2be93ee3 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -31,18 +31,18 @@ GECKO_CONFING?= ${LOCALBASE}/bin/${GECKO}-config
XPIDL?= ${LOCALBASE}/lib/${GECKO}/xpidl
XPIDL_INCL?= `${GECKO_CONFIG} --idlflags`
-BUILD_DEPENDS+= libxul>=31:${PORTSDIR}/www/libxul
-RUN_DEPENDS+= libxul>=31:${PORTSDIR}/www/libxul
+BUILD_DEPENDS+= libxul>=38:${PORTSDIR}/www/libxul
+RUN_DEPENDS+= libxul>=38:${PORTSDIR}/www/libxul
.elif ${gecko_ARGS:Mfirefox}
-_GECKO_DEFAULT_VERSION= 31
-_GECKO_VERSIONS= 31 38
+_GECKO_DEFAULT_VERSION= 38
+_GECKO_VERSIONS= 38 39
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
-31_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
-38_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+38_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
+39_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index a811462eac0e..3e7160ea930b 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -161,8 +161,8 @@ icu_LIB_DEPENDS= libicui18n.so:${PORTSDIR}/devel/icu
icu_MOZ_OPTIONS= --with-system-icu --with-intl-api
-jpeg_BUILD_DEPENDS=yasm:${PORTSDIR}/devel/yasm
-# XXX depends on ports/180159 or package flavor support
-#jpeg_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/libjpeg-turbo
+# XXX JCS_EXTENSIONS API is currently disabled by r371283
+# XXX Remove files/patch-ijg-libjpeg once -turbo is default
jpeg_USES= jpeg
jpeg_MOZ_OPTIONS= --with-system-jpeg=${LOCALBASE}