aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-17 13:01:35 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-17 13:01:35 +0000
commitcd25ab5604ef730def1269442367d8f8e190a7f5 (patch)
tree43987acb396edae533ae5bb903cf7bc5f7936d88 /Mk
parentcf47688c9464a6e75662c73e34eb5fc4bacadca7 (diff)
downloadports-cd25ab5604ef730def1269442367d8f8e190a7f5.tar.gz
ports-cd25ab5604ef730def1269442367d8f8e190a7f5.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gnustep.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/Mk/bsd.gnustep.mk b/Mk/bsd.gnustep.mk
index 8f1c526835bb..a38f2c02fbaf 100644
--- a/Mk/bsd.gnustep.mk
+++ b/Mk/bsd.gnustep.mk
@@ -75,6 +75,9 @@
# USE_GNUSTEP_LOCAL_LIBS+= pantomime:mail/pantomime
# depends on a shared lib in Local directrory
#
+# USE_GNUSTEP_LOCAL_BUNDLES+= Cddb:audio/cddb-bundle
+# depends on Bundles installed in Local directrory at build and runtime
+#
# USE_GNUSTEP_SYSTEM_APPS+= ProjectCenter:devel/projectcenter.app
# depends on Application installed in System directrory at runtime
#
@@ -281,6 +284,16 @@ RUN_DEPENDS+= ${LOCALLIBDIR}/lib${_GNUSTEP_DEP:C/:.*//}.so:${PORTSDIR}/${_GNUSTE
.endif
# ---------------------------------------------------------------------------
+# source local bundles
+#
+.if defined(USE_GNUSTEP_LOCAL_BUNDLES)
+.for _GNUSTEP_DEP in ${USE_GNUSTEP_LOCAL_BUNDLES}
+BUILD_DEPENDS+= ${GNUSTEP_PREFIX}/Local/Library/Bundles/${_GNUSTEP_DEP:C/:.*//}.bundle/${_GNUSTEP_DEP:C/:.*//}:${PORTSDIR}/${_GNUSTEP_DEP:C/.*://}
+RUN_DEPENDS+= ${GNUSTEP_PREFIX}/Local/Library/Bundles/${_GNUSTEP_DEP:C/:.*//}.bundle/${_GNUSTEP_DEP:C/:.*//}:${PORTSDIR}/${_GNUSTEP_DEP:C/.*://}
+.endfor
+.endif
+
+# ---------------------------------------------------------------------------
# source system apps
#
.if defined(USE_GNUSTEP_SYSTEM_APPS)