aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-03-30 18:36:30 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-03-30 18:36:30 +0000
commitdb738ec122706c6d1c767ef1ef2d26bc6e2fa1f8 (patch)
treefa8cca567cb1e54f79c00e9de3936c333c27222c /Mk
parent5680c38c53cf4d1a7b497808c91d04d86d963d0d (diff)
downloadports-db738ec122706c6d1c767ef1ef2d26bc6e2fa1f8.tar.gz
ports-db738ec122706c6d1c767ef1ef2d26bc6e2fa1f8.zip
Mk/Uses/php.mk: Flag invalid args
Approved by: ale (maintainer) Differential Revision: https://reviews.freebsd.org/D19750
Notes
Notes: svn path=/head/; revision=497318
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/php.mk15
1 files changed, 14 insertions, 1 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index 22975d6b6664..778400de999a 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -4,7 +4,8 @@
#
# Feature: php
# Usage: USES=php
-# Valid ARGS: (none), phpize, ext, zend, build, cli, cgi, mod, web, embed
+# Valid ARGS: (none), phpize, ext, zend, build, cli, cgi, mod, web, embed,
+# pecl, flavors, noflavors
#
# - phpize : Use to build a PHP extension.
# - ext : Use to build, install and register a PHP extension.
@@ -60,6 +61,18 @@ PHP_Include_MAINTAINER= ale@FreeBSD.org
_INCLUDE_USES_PHP_MK= yes
+_PHP_VALID_ARGS= build cgi cli embed ext flavors mod noflavors pecl \
+ phpize web zend
+_PHP_UNKNOWN_ARGS=
+.for arg in ${php_ARGS}
+. if empty(_PHP_VALID_ARGS:M${arg})
+_PHP_UNKNOWN_ARGS+= ${arg}
+. endif
+.endfor
+.if !empty(_PHP_UNKNOWN_ARGS)
+IGNORE= has unknown USES=php arguments: ${_PHP_UNKNOWN_ARGS}
+.endif
+
. if ${php_ARGS:Mbuild} && ( ${php_ARGS:Mphpize} || ${php_ARGS:Mext} || ${php_ARGS:Mzend} )
DEV_WARNING+= "USES=php:build is included in USES=php:phpize, USES=php:ext, and USES=php:zend, so it is not needed"
. endif