aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-13 22:10:33 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-13 22:10:33 +0000
commit43b5db1e289fc66c750c7bde928537e273ca7eb1 (patch)
tree49a869eedb5259ea3c23d9cfd0c9ecb71f94c031 /Mk
parent58b87661cde113f8460233f17eacbbeff95262c7 (diff)
downloadports-43b5db1e289fc66c750c7bde928537e273ca7eb1.tar.gz
ports-43b5db1e289fc66c750c7bde928537e273ca7eb1.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.perl.mk25
-rw-r--r--Mk/bsd.port.mk12
2 files changed, 22 insertions, 15 deletions
diff --git a/Mk/bsd.perl.mk b/Mk/bsd.perl.mk
index 61b4fd80f16d..543d1088a00a 100644
--- a/Mk/bsd.perl.mk
+++ b/Mk/bsd.perl.mk
@@ -111,11 +111,6 @@ SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
PERL5= ${LOCALBASE}/bin/perl${PERL_VERSION}
PERL= ${LOCALBASE}/bin/perl
-PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
- PERL_VER=${PERL_VER} \
- PERL_ARCH=${PERL_ARCH} \
- SITE_PERL=${SITE_PERL_REL}
-
.endif # defined(_PERL_REFACTORING_COMPLETE)
# Decide where to look for the version string
@@ -172,6 +167,21 @@ IGNORE= improper use of USE_PERL5
.endif
.endif #${USE_PERL5_STRING:L} != "yes"
+.endif # !defined(_POSTMKINCLUDED) && !defined(Perl_Pre_Include)
+
+.if defined(_POSTMKINCLUDED) && !defined(Perl_Post_Include)
+
+Perl_Post_Include= bsd.perl.mk
+
+.if defined(_PERL_REFACTORING_COMPLETE)
+
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL_REL}
+
+.endif # defined(_PERL_REFACTORING_COMPLETE)
+
.if defined(PERL_MODBUILD)
PERL_CONFIGURE= yes
CONFIGURE_SCRIPT?= Build.PL
@@ -215,11 +225,6 @@ CONFIGURE_SCRIPT?= Makefile.PL
MAN3PREFIX?= ${PREFIX}/lib/perl5/${PERL_VERSION}
.undef HAS_CONFIGURE
.endif # defined(PERL_CONFIGURE)
-.endif # !defined(_POSTMKINCLUDED) && !defined(Perl_Pre_Include)
-
-.if defined(_POSTMKINCLUDED) && !defined(Perl_Post_Include)
-
-Perl_Post_Include= bsd.perl.mk
.if defined(PERL_CONFIGURE)
.if !target(do-configure)
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ab08c18fe18b..5d0020c1a2b8 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1422,11 +1422,6 @@ SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
PERL5= ${LOCALBASE}/bin/perl${PERL_VERSION}
PERL= ${LOCALBASE}/bin/perl
-PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
- PERL_VER=${PERL_VER} \
- PERL_ARCH=${PERL_ARCH} \
- SITE_PERL=${SITE_PERL_REL}
-
.endif # !defined(_PERL_REFACTORING_COMPLETE)
.if defined(USE_LOCAL_MK)
@@ -1936,6 +1931,13 @@ RUN_DEPENDS+= ${_GL_${_component}_RUN_DEPENDS}
BUILD_DEPENDS+= bison:${PORTSDIR}/devel/bison
.endif
+.if !defined(_PERL_REFACTORING_COMPLETE)
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL_REL}
+.endif # !defined(_PERL_REFACTORING_COMPLETE)
+
.if defined(USE_LOCAL_MK)
.include "${PORTSDIR}/Mk/bsd.local.mk"
.endif