aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-09-05 09:07:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-09-05 09:07:49 +0000
commit56f344f8c968347544fd0fc3e42ccba595d96850 (patch)
treef989a89feabcc22f4ce795772f76f4e54a3d6d50 /Mk
parent3d38f93a9d311332799815e6dbf48c22d033f6be (diff)
downloadports-56f344f8c968347544fd0fc3e42ccba595d96850.tar.gz
ports-56f344f8c968347544fd0fc3e42ccba595d96850.zip
Fix make deinstall-depends with pkg.
drop pkg itself from the list of deinstall-depends in order to keep pkg around to be able to deinstall more ports. PR: 204296 Reported by: ian
Notes
Notes: svn path=/head/; revision=511161
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1c68343b6943..e2845e6b98be 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4046,6 +4046,7 @@ DEPENDS-LIST= \
ALL-DEPENDS-LIST= ${DEPENDS-LIST} -r ${_UNIFIED_DEPENDS:Q}
ALL-DEPENDS-FLAVORS-LIST= ${DEPENDS-LIST} -f -r ${_UNIFIED_DEPENDS:Q}
+DEINSTALL-DEPENDS-FLAVORS-LIST= ${DEPENDS-LIST} -f -r ${_UNIFIED_DEPENDS:N${PKG_DEPENDS}:Q}
MISSING-DEPENDS-LIST= ${DEPENDS-LIST} -m ${_UNIFIED_DEPENDS:Q}
BUILD-DEPENDS-LIST= ${DEPENDS-LIST} "${PKG_DEPENDS} ${EXTRACT_DEPENDS} ${PATCH_DEPENDS} ${FETCH_DEPENDS} ${BUILD_DEPENDS} ${LIB_DEPENDS}"
RUN-DEPENDS-LIST= ${DEPENDS-LIST} "${LIB_DEPENDS} ${RUN_DEPENDS}"
@@ -4070,7 +4071,7 @@ limited-clean-depends:
.if !target(deinstall-depends)
deinstall-depends:
@recursive_cmd="deinstall"; \
- recursive_dirs="$$(${ALL-DEPENDS-FLAVORS-LIST})"; \
+ recursive_dirs="$$(${DEINSTALL-DEPENDS-FLAVORS-LIST})"; \
${_FLAVOR_RECURSIVE_SH}
.endif