aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-09-01 13:42:47 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-09-01 13:42:47 +0000
commit86ed19b18b4c2b17c1b362afff609bbb631ad422 (patch)
tree74f0d9938210ae7ba51998a3d92b43478d8d1b7e /Mk
parentbc78044598a4a989db76b38a8508188da5bfb4bd (diff)
downloadports-86ed19b18b4c2b17c1b362afff609bbb631ad422.tar.gz
ports-86ed19b18b4c2b17c1b362afff609bbb631ad422.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1b772b6a1118..746f484f8100 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3432,7 +3432,7 @@ do-fetch:
esac; \
if ${SETENV} ${FETCH_ENV} ${FETCH_CMD} ${FETCH_BEFORE_ARGS} $${args} ${FETCH_AFTER_ARGS}; then \
actual_size=`stat -f %z "$${file}"`; \
- if [ $${actual_size} -eq $${CKSIZE} ]; then \
+ if [ -n "${DISABLE_SIZE}" ] || [ $${actual_size} -eq $${CKSIZE} ]; then \
continue 2; \
else \
${ECHO_MSG} "=> Fetched file size mismatch (expected $${CKSIZE}, actual $${actual_size})"; \