aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-08-21 18:06:58 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-08-21 18:06:58 +0000
commitb154a5521fc93776fbbc6f165458b305ec5189b8 (patch)
treeebfec4bc0f09be3e6e59e3fd320df8306afc1f88 /Mk
parentb79b3f1ca2719a13717cdf07910f2fc4722cb71d (diff)
downloadports-b154a5521fc93776fbbc6f165458b305ec5189b8.tar.gz
ports-b154a5521fc93776fbbc6f165458b305ec5189b8.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.apache.mk6
-rw-r--r--Mk/bsd.options.mk4
2 files changed, 5 insertions, 5 deletions
diff --git a/Mk/bsd.apache.mk b/Mk/bsd.apache.mk
index 7757d37d3085..e9067e126d30 100644
--- a/Mk/bsd.apache.mk
+++ b/Mk/bsd.apache.mk
@@ -143,7 +143,7 @@ IGNORE= lowercase WITH_STATIC_MODULES="${WITH_STATIC_MODULES}"\
# Setting "@comment " as default.
.for module in ${AVAILABLE_MODULES:O}
-${module}_PLIST_SUB= "@comment "
+${module}PLIST_SUB= "@comment "
_DISABLE_MODULES+= --disable-${module:tl}
.endfor
@@ -244,11 +244,11 @@ SHARED_MODULES= ${APACHE_MODULES}
.endif
.for module in ${SHARED_MODULES}
-${module}_PLIST_SUB= ""
+${module}PLIST_SUB= ""
.endfor
.for module in ${AVAILABLE_MODULES:O:u}
-PLIST_SUB+= MOD_${module}=${${module}_PLIST_SUB}
+PLIST_SUB+= MOD_${module}=${${module}PLIST_SUB}
.endfor
# pkg-plist workaround STATIC support
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index b37bdff6e19b..1f99ca641b34 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -104,7 +104,7 @@
# ALL_TARGET CATEGORIES CFLAGS CONFIGURE_ENV CONFLICTS CONFLICTS_BUILD
# CONFLICTS_INSTALL CPPFLAGS CXXFLAGS DISTFILES EXTRA_PATCHES
# INSTALL_TARGET LDFLAGS LIBS MAKE_ARGS MAKE_ENV PATCHFILES PATCH_SITES
-# PLIST_DIRS PLIST_DIRSTRY PLIST_FILES INFO USES, defining ${opt}_${variable} will
+# PLIST_DIRS PLIST_DIRSTRY PLIST_FILES PLIST_SUB INFO USES, defining ${opt}_${variable} will
# add its content to the actual variable when the option is enabled. Defining
# ${opt}_${variable}_OFF will add its content to the actual variable when the
# option is disabled.
@@ -130,7 +130,7 @@ _OPTIONS_FLAGS= ALL_TARGET CATEGORIES CFLAGS CONFIGURE_ENV CONFLICTS \
CONFLICTS_BUILD CONFLICTS_INSTALL CPPFLAGS CXXFLAGS DISTFILES \
EXTRA_PATCHES INSTALL_TARGET LDFLAGS LIBS MAKE_ARGS MAKE_ENV \
PATCHFILES PATCH_SITES PLIST_DIRS PLIST_DIRSTRY PLIST_FILES \
- USES INFO
+ PLIST_SUB USES INFO
_OPTIONS_DEPENDS= PKG FETCH EXTRACT PATCH BUILD LIB RUN
# Set the default values for the global options, as defined by portmgr