aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-10-01 04:13:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-10-01 04:13:31 +0000
commitc45de9579f6ec97574056dd335df02031ccd00ad (patch)
treebf42b7c476faa7a6183d0feaa4c65bb90053847d /Mk
parent4c6b47d49f526e4aa085f3d82bef3b2910453e64 (diff)
downloadports-c45de9579f6ec97574056dd335df02031ccd00ad.tar.gz
ports-c45de9579f6ec97574056dd335df02031ccd00ad.zip
Qt5 update to 5.13.0
For new features, check: https://wiki.qt.io/New_Features_in_Qt_5.13 Thanks to adridg who helped to fix a lot of packages. Exp-run by: antoine PR: 238782
Notes
Notes: svn path=/head/; revision=513447
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/qt-dist.mk28
-rw-r--r--Mk/Uses/qt.mk12
2 files changed, 26 insertions, 14 deletions
diff --git a/Mk/Uses/qt-dist.mk b/Mk/Uses/qt-dist.mk
index 92126b46558b..718c9b9d1a79 100644
--- a/Mk/Uses/qt-dist.mk
+++ b/Mk/Uses/qt-dist.mk
@@ -21,13 +21,13 @@ qmake_ARGS?= # empty
.include "${USESDIR}/qmake.mk"
# Supported distribution arguments
-_QT5_DISTS= 3d activeqt androidextras base canvas3d charts connectivity \
- datavis3d declarative doc gamepad graphicaleffects imageformats \
- location macextras multimedia networkauth purchasing \
- quickcontrols2 quickcontrols remoteobjects script scxml sensors \
- serialbus serialport speech svg tools translations \
- virtualkeyboard wayland webchannel webengine websockets webview \
- winextras x11extras xmlpatterns
+_QT5_DISTS= 3d activeqt androidextras base charts connectivity datavis3d \
+ declarative doc gamepad graphicaleffects imageformats location \
+ lottie macextras multimedia networkauth purchasing quickcontrols \
+ quickcontrols2 remoteobjects script scxml sensors serialbus \
+ serialport speech svg tools translations virtualkeyboard wayland \
+ webchannel webengine webglplugin websockets webview winextras \
+ x11extras xmlpatterns
_QT_DISTS= ${_QT${_QT_VER}_DISTS}
# We only accept one item as an argument. The fetch target further below works
@@ -170,7 +170,8 @@ CONFIGURE_ARGS+= -verbose
_EXTRA_PATCHES_QT5= ${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_features_create__cmake.prf \
${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_features_qt__module.prf \
${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_common_bsd_bsd.conf \
- ${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_freebsd-clang_qmake.conf
+ ${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_freebsd-clang_qmake.conf \
+ ${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_features_data_cmake_Qt5BasicConfig.cmake.in
. if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
_EXTRA_PATCHES_QT5+= ${PORTSDIR}/devel/${_QT_RELNAME}/files/extra-patch-mkspecs_common_g++-base.conf \
${PORTSDIR}/devel/${_QT_RELNAME}/files/extra-patch-mkspecs_common_gcc-base.conf \
@@ -247,6 +248,7 @@ _QT_TOOLS+= ${UIC}
# The list of QtBase components that need to be linked into WRKSRC/lib for
# other QtBase ports. See below.
_QT5_BASE= core dbus gui network sql widgets
+_QT5_ADDITIONAL_LINK?= # Ensure definition
.if ${_QT_VER:M5}
post-patch: gcc-post-patch
@@ -332,6 +334,16 @@ qt5-pre-configure:
${ECHO_CMD} 'QMAKE_DEFAULT_LIBDIRS += ${LOCALBASE}/lib /usr/lib /lib' >> ${CONFIGURE_WRKSRC}/.qmake.cache
${ECHO_CMD} 'QMAKE_DEFAULT_INCDIRS += ${LOCALBASE}/include /usr/include' >> ${CONFIGURE_WRKSRC}/.qmake.cache
+# Allow linking of further libraries to the configure directory.
+. if !empty(_QT5_ADDITIONAL_LINK)
+. for dep in ${_QT5_ADDITIONAL_LINK}
+ ${MKDIR} ${CONFIGURE_WRKSRC}/lib
+. if ! empty(USE_QT:M${dep})
+ ${LN} -sf ${QT_LIBDIR}/${qt-${dep}_LIB} ${CONFIGURE_WRKSRC}/lib
+. endif
+. endfor
+. endif
+
post-install: qt-post-install
qt-post-install:
. if ${QT_DEFINES:N-*}
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index d99d4c6aa9cc..65eb9b143800 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -22,7 +22,7 @@ _QT_MK_INCLUDED= qt.mk
# Qt versions currently supported by the framework.
_QT_SUPPORTED?= 5
-QT5_VERSION?= 5.12.2
+QT5_VERSION?= 5.13.0
# We accept the Qt version to be passed by either or all of the three mk files.
. if empty(qt_ARGS) && empty(qmake_ARGS) && empty(qt-dist_ARGS)
@@ -134,12 +134,12 @@ _USE_QT_ALL= assistant dbus declarative designer doc gui help \
_USE_QT_ALL+= sql-ibase
.endif
-_USE_QT5_ONLY= 3d buildtools canvas3d charts concurrent connectivity \
+_USE_QT5_ONLY= 3d buildtools charts concurrent connectivity \
core datavis3d diag examples gamepad \
graphicaleffects location networkauth paths phonon4 plugininfo printsupport \
qdbus qdoc qdoc-data qev quickcontrols \
quickcontrols2 remoteobjects scxml sensors serialbus serialport speech \
- sql-tds uiplugin uitools virtualkeyboard wayland webchannel \
+ sql-tds uiplugin uitools virtualkeyboard wayland webchannel webglplugin \
webengine websockets websockets-qml webview widgets x11extras
# Dependency tuples: _LIB should be preferred if possible.
@@ -152,9 +152,6 @@ qt-assistant_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/assistant
qt-buildtools_PORT= devel/${_QT_RELNAME}-buildtools
qt-buildtools_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/moc
-qt-canvas3d_PORT= x11-toolkits/${_QT_RELNAME}-canvas3d
-qt-canvas3d_PATH= ${LOCALBASE}/${QT_QMLDIR_REL}/QtCanvas3D/qmldir
-
qt-charts_PORT= x11-toolkits/${_QT_RELNAME}-charts
qt-charts_LIB= libQt${_QT_LIBVER}Charts.so
@@ -326,6 +323,9 @@ qt-webchannel_LIB= libQt${_QT_LIBVER}WebChannel.so
qt-webengine_PORT= www/${_QT_RELNAME}-webengine
qt-webengine_LIB= libQt${_QT_LIBVER}WebEngine.so
+qt-webglplugin_PORT= www/${_QT_RELNAME}-webglplugin
+qt-webglplugin_PATH= ${LOCALBASE}/${QT_PLUGINDIR_REL}/platforms/libqwebgl.so
+
qt-websockets_PORT= www/${_QT_RELNAME}-websockets
qt-websockets_LIB= libQt${_QT_LIBVER}WebSockets.so