aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-09-19 23:46:33 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-09-19 23:46:33 +0000
commite69e6941cc0f1dab5aefa920fb26c0f26941f258 (patch)
treee3316902afbb4318b0439dc574f0496749ecfdc3 /Mk
parent1e85daf0f563c93a39304c113d346f778baccbd8 (diff)
downloadports-e69e6941cc0f1dab5aefa920fb26c0f26941f258.tar.gz
ports-e69e6941cc0f1dab5aefa920fb26c0f26941f258.zip
Welcome XFCE 4.14 to the FreeBSD ports tree
- This XFCE release uses almost exclusively gtk3, so the USES=xfce now defaults to gtk3 - Make x11-themes/gtk-xfce-engine an optional dependency(disabled by default), it only supports gtk2, so would leave miost of this XFCE version unthemed. - Add Greybird as an optional and enabled dependency as a modern theme supporting both GTK versions and all other XFCE parts - The xfce4-vala port is deprecated and removed. The VALA bindings are available in the library ports using the GIR and VAPI options (on by default) - Fixed various missing library and portlint warnings (portmgr fixit blanket) - Default Display Manager changed to lightdm (Thanks to woodsb02 for help) - Add x11/xfce4-screensaver as an optional dependency to the xfce4-goodies (enabled by default) - Remove dependency on x11-fm/thunar-vfs and deprecate the port. It is EOL upstream and the functionality is included in thunar itself Update: - Added back sysutils/xfce4-places-plugin, updated to 1.8.1 - archivers/thunar-archive-plugin to 0.4.0 - audio/thunar-media-tags-plugin to 0.3.0 - audio/xfce4-mpc-plugin to 0.5.2 - audio/xfce4-pulseaudio-plugin to 0.4.2 - deskutils/xfce4-tumbler to 0.2.7 - devel/thunar-vcs-plugin to 0.2.0 [1] - devel/xfce4-dev-tools to 4.14.0 - misc/xfce4-appfinder to 4.14.0 - misc/xfce4-weather-plugin to 0.10.0 - multimedia/xfce4-parole to 1.0.4 - sysutils/gigolo to 0.5.0 - sysutils/xfce4-battery-plugin to 1.1.3 - sysutils/xfce4-fsguard-plugin to 1.1.1 - sysutils/xfce4-netload-plugin to 1.3.2 - sysutils/xfce4-power-manage to 1.6.5 - sysutils/xfce4-settings 4.14.1 - sysutils/xfce4-systemload-plugin to 1.2.3 - sysutils/xfce4-wavelan-plugin to 0.6.1 - www/xfce4-smartbookmark-plugin to 0.5.1 - x11-clocks/xfce4-datetime-plugin to 0.8.0 - Added new xfce4-stopwatch-plugin, version 0.3.1 - x11-clocks/xfce4-timer-out-plugin to 1.0.3 - x11-fm/thunar to 1.8.9 - x11-wm/xfce4-desktop to 4.14.1 - x11-wm/xfce4-panel to 4.14.0 - x11-wm/xfce4-session to 4.14.0 - x11-wm/xfce4-wm to 4.14.0 - x11/libexo to 0.12.8 - x11/libxfce4menu to 4.14.1 - x11/libxfce4util to 4.14.0 - x11/xfce4-conf to 4.14.1 - x11/xfce4-dashboard to 0.7.5 - x11/xfce4-screensaver to 0.1.8 - x11/xfce4-screenshooter-plugin to 1.9.6 - x11/xfce4-verve-plugin to 2.0.0 Thanks to: Olivier Duchateau <duchateau.olivier@gmail.com> PR: 240236 Exp-run by: antoine Tested by: sbruno Approved by: sergey.dyatko@gmail.com (maintainer timeout via email), portmgr (fixit blanket, port breaks with new Thunar if not updated) [1] Differential Revision: https://reviews.freebsd.org/D21278
Notes
Notes: svn path=/head/; revision=512378
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/xfce.mk31
1 files changed, 17 insertions, 14 deletions
diff --git a/Mk/Uses/xfce.mk b/Mk/Uses/xfce.mk
index c67a5e5fceb7..42f62fafa5c1 100644
--- a/Mk/Uses/xfce.mk
+++ b/Mk/Uses/xfce.mk
@@ -5,7 +5,7 @@
#
# Feature: xfce
# Usage: USES=xfce or USES=xfce:ARGS
-# Valid ARGS: gtk3
+# Valid ARGS: gtk2
#
# Variables, which can be set by the port:
#
@@ -24,37 +24,40 @@ xfce_ARGS?= # empty
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-.if ${xfce_ARGS:Mgtk3}
-libmenu_LIB_DEPENDS= libxfce4ui-2.so:x11/libxfce4menu
-libmenu_USE_XFCE_REQ= xfconf
+.if ${xfce_ARGS:Mgtk2}
+libmenu_LIB_DEPENDS= libxfce4ui-1.so:x11/libxfce4menu
+libmenu_USE_XFCE_REQ= libutil
-garcon_LIB_DEPENDS= libgarcon-gtk3-1.so:sysutils/garcon
+garcon_LIB_DEPENDS= libgarcon-gtk2-1.so:sysutils/garcon
garcon_USE_XFCE_REQ= libmenu
-panel_LIB_DEPENDS= libxfce4panel-2.0.so:x11-wm/xfce4-panel
+libexo_LIB_DEPENDS= libexo-1.so:x11/libexo
+libexo_USE_XFCE_REQ= libmenu
+
+panel_LIB_DEPENDS= libxfce4panel-1.0.so:x11-wm/xfce4-panel
panel_RUN_DEPENDS= xfce4-panel:x11-wm/xfce4-panel
panel_USE_XFCE_REQ= garcon libexo xfconf
.else
-libmenu_LIB_DEPENDS= libxfce4ui-1.so:x11/libxfce4menu
-libmenu_USE_XFCE_REQ= xfconf
+libmenu_LIB_DEPENDS= libxfce4ui-2.so:x11/libxfce4menu
+libmenu_USE_XFCE_REQ= libutil
-garcon_LIB_DEPENDS= libgarcon-gtk2-1.so:sysutils/garcon
+garcon_LIB_DEPENDS= libgarcon-gtk3-1.so:sysutils/garcon
garcon_USE_XFCE_REQ= libmenu
-panel_LIB_DEPENDS= libxfce4panel-1.0.so:x11-wm/xfce4-panel
+libexo_LIB_DEPENDS= libexo-2.so:x11/libexo
+libexo_USE_XFCE_REQ= libmenu
+
+panel_LIB_DEPENDS= libxfce4panel-2.0.so:x11-wm/xfce4-panel
panel_RUN_DEPENDS= xfce4-panel:x11-wm/xfce4-panel
panel_USE_XFCE_REQ= garcon libexo xfconf
.endif
-libexo_LIB_DEPENDS= libexo-1.so:x11/libexo
-libexo_USE_XFCE_REQ= libmenu
-
libgui_LIB_DEPENDS= libxfcegui4.so:x11-toolkits/libxfce4gui
libgui_USE_XFCE_REQ= libutil
libutil_LIB_DEPENDS= libxfce4util.so:x11/libxfce4util
-thunar_LIB_DEPENDS= libthunarx-2.so:x11-fm/thunar
+thunar_LIB_DEPENDS= libthunarx-3.so:x11-fm/thunar
thunar_RUN_DEPENDS= Thunar:x11-fm/thunar
thunar_USE_XFCE_REQ= xfconf libmenu