aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-09-19 09:34:36 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-09-19 09:34:36 +0000
commit19c76400cc7cd5106b3b3c4a92c40d8f47dac813 (patch)
tree4692a8ac5bbcb6edb1d8a8953030e3fa6a7329e5 /Mk
parenta55db457da83f8c69590ee9f4b08efc753c98b08 (diff)
downloadports-19c76400cc7cd5106b3b3c4a92c40d8f47dac813.tar.gz
ports-19c76400cc7cd5106b3b3c4a92c40d8f47dac813.zip
mesa-libs: Add glesv1 lib
There is no real reason to disable glesv1 so add it to the build. While here add a USE_GL for it. Reviewed by: zeising Approved by: x11 (zeising@) Differential Revision: https://reviews.freebsd.org/D26461
Notes
Notes: svn path=/head/; revision=548950
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gl.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/Uses/gl.mk b/Mk/Uses/gl.mk
index 865a43a67dce..79cac03a943d 100644
--- a/Mk/Uses/gl.mk
+++ b/Mk/Uses/gl.mk
@@ -4,7 +4,7 @@
#
# Feature: gl
# Usage: USES=gl
-# USE_GL=egl gbm gl glesv2 glew glu glut
+# USE_GL=egl gbm gl glesv1 glesv2 glew glu glut
#
# USE_GL specifies which GL components to add as dependencies.
# Not specifying USE_GL with USES=gl is an error.
@@ -19,6 +19,7 @@ _GL_egl_LIB_DEPENDS= libEGL.so:graphics/mesa-libs
_GL_gbm_LIB_DEPENDS= libgbm.so:graphics/mesa-libs
_GL_gl_LIB_DEPENDS= libGL.so:graphics/mesa-libs
_GL_gl_USE_XORG= xorgproto
+_GL_glesv1_LIB_DEPENDS= libGLESv1_CM.so:graphics/mesa-libs
_GL_glesv2_LIB_DEPENDS= libGLESv2.so:graphics/mesa-libs
_GL_glew_LIB_DEPENDS= libGLEW.so:graphics/glew
_GL_glu_LIB_DEPENDS= libGLU.so:graphics/libGLU