aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-12-13 03:22:22 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-12-13 03:22:22 +0000
commit261177b8bdb2bd66803e65d7bf72466748a0ad5e (patch)
tree760fd3a3d97df8178f5626b01fb304a00d1d38f9 /Mk
parentce5467924417a1cd8c93ec75a32f228e8af5a7e9 (diff)
downloadports-261177b8bdb2bd66803e65d7bf72466748a0ad5e.tar.gz
ports-261177b8bdb2bd66803e65d7bf72466748a0ad5e.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 6c02eb096d7f..d584cb789b81 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -110,6 +110,9 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# PYCTYPES - Dependency line for the ctypes package. As of Python-2.5,
# this module is in the base distribution.
#
+# PYHASHLIB - Dependency line for the hashlib package. As of Python-2.5,
+# this module is in the base distribution.
+#
# USE_PYTHON_PREFIX - Says that the port installs in ${PYTHONBASE}.
#
# USE_PYDISTUTILS - Use distutils as do-configure, do-build and do-install
@@ -441,6 +444,12 @@ PYCTYPES= ${PYTHON_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
PYCTYPES= ${PYTHON_LIBDIR}/ctypes/__init__py:${PYTHON_PORTSDIR}
.endif
+.if defined(PYTHON_REL) && ${PYTHON_REL} < 250
+PYHASHLIB= ${PYTHON_SITELIBDIR}/hashlib.py:${PORTSDIR}/security/py-hashlib
+.else
+PYHASHLIB= ${PYTHON_LIBDIR}/hashlib.py:${PYTHON_PORTSDIR}
+.endif
+
# dependencies
PYTHON_NO_DEPENDS?= NO