aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-09-19 20:22:27 +0000
committerRene Ladan <rene@FreeBSD.org>2020-09-19 20:22:27 +0000
commit57a977d8a2f03ad5195f3867d324e59e9d4eaf72 (patch)
treed37829c1ee42c693cd40f241e0a4b2a64629a9e2 /Mk
parentdc7620de2791582db950520a59b60cee35bd893d (diff)
downloadports-57a977d8a2f03ad5195f3867d324e59e9d4eaf72.tar.gz
ports-57a977d8a2f03ad5195f3867d324e59e9d4eaf72.zip
Unregister expired Python 3.5
Notes
Notes: svn path=/head/; revision=549060
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/python.mk8
-rw-r--r--Mk/bsd.default-versions.mk4
2 files changed, 6 insertions, 6 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index cafd46005d4a..8c553cbb5399 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -250,7 +250,7 @@ _INCLUDE_USES_PYTHON_MK= yes
# What Python version and what Python interpreters are currently supported?
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
-_PYTHON_VERSIONS= 2.7 3.7 3.8 3.6 3.5 # preferred first
+_PYTHON_VERSIONS= 2.7 3.7 3.8 3.6 # preferred first
_PYTHON_PORTBRANCH= 2.7 # ${_PYTHON_VERSIONS:[1]}
_PYTHON_BASECMD= ${LOCALBASE}/bin/python
_PYTHON_RELPORTDIR= lang/python
@@ -329,7 +329,7 @@ DEV_WARNING+= "lang/python27 reached End of Life and will be removed on 2020-12
.elif ${_PYTHON_ARGS} == 2
DEV_ERROR+= "USES=python:2 is no longer supported, use USES=python:2.7"
.elif ${_PYTHON_ARGS} == 3
-DEV_ERROR+= "USES=python:3 is no longer supported, use USES=python:3.5+ or an appropriate version range"
+DEV_ERROR+= "USES=python:3 is no longer supported, use USES=python:3.6+ or an appropriate version range"
.endif # ${_PYTHON_ARGS} == 2.7
_PYTHON_VERSION:= ${PYTHON_DEFAULT}
@@ -428,7 +428,7 @@ PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
# To avoid having dependencies with @ and empty flavor:
# _PYTHON_VERSION is either set by (first that matches):
# - If using Python flavors, from the current Python flavor
-# - If using a version restriction (USES=python:3.5+), from the first
+# - If using a version restriction (USES=python:3.6+), from the first
# acceptable default Python version.
# - From PYTHON_DEFAULT
PY_FLAVOR= py${_PYTHON_VERSION:S/.//}
@@ -458,7 +458,7 @@ PYTHON_CMD?= ${_PYTHON_BASECMD}${_PYTHON_VERSION}
.if exists(${PYTHON_CMD}-config)
PYTHON_ABIVER!= ${PYTHON_CMD}-config --abiflags
.elif ${PYTHON_REL} < 3800
-# Default ABI flags for lang/python3[567] ports
+# Default ABI flags for lang/python3[67] ports
PYTHON_ABIVER= m
.endif
.endif
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 618dfaaeba89..ea4a88496f72 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -90,11 +90,11 @@ PERL5_DEFAULT:= ${_PERL5_FROM_BIN:R}
PGSQL_DEFAULT?= 11
# Possible values: 7.2, 7.3, 7.4
PHP_DEFAULT?= 7.4
-# Possible values: 2.7, 3.5, 3.6, 3.7, 3.8
+# Possible values: 2.7, 3.6, 3.7, 3.8
PYTHON_DEFAULT?= 3.7
# Possible values: 2.7
PYTHON2_DEFAULT?= 2.7
-# Possible values: 3.5, 3.6, 3.7, 3.8
+# Possible values: 3.6, 3.7, 3.8
PYTHON3_DEFAULT?= 3.7
# Possible values: 2.5, 2.6, 2.7
RUBY_DEFAULT?= 2.6