aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-07-06 06:43:37 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-07-06 06:43:37 +0000
commit5f34284e7c01f03ee6735e7fcd3ec5783ab11777 (patch)
tree46cfcccc197bb0d79ee8c9868007fd48adf2470d /Mk
parent5e1f836349896a33cdb608a4b696d10528aa8393 (diff)
downloadports-5f34284e7c01f03ee6735e7fcd3ec5783ab11777.tar.gz
ports-5f34284e7c01f03ee6735e7fcd3ec5783ab11777.zip
Update Qt5 to 5.15
This is a major upgrade of the Qt libraries [1], [2]. * People that use upgrading mechanisms with incomplete dependency handling (portmaster & Co) should make sure to manually remove the existing Qt packages to guarantee a safe upgrade. Keep in mind, that Qt does not like if you have an incomplete upgrade. * This version of Qt drops support for OpenSSL 1.0 -- this means that there won't be any binary packages for Qt5 provided by the FreeBSD package builders for FreeBSD 11.x anymore -- and the same for *all* the ports depending on net/qt5-network [3]. If you cannot upgrade to a more recent FreeBSD version (12.x, 13.x), you will need to build Qt5 from ports while switching to an SSL implementation from ports. Big thanks are due for * kai@ for updating webengine (also mikael@) * Felix Palmen for providing LibreSSL support patches * adridg@ and lbartoletti@ for helping me fix the fallout [1] https://www.qt.io/blog/qt-5.15-released [2] https://wiki.qt.io/New_Features_in_Qt_5.15 [3] https://www.freshports.org/net/qt5-network PR: 247010 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=541318
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/qt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index c395a2e98b57..f47ab782f715 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -24,7 +24,7 @@ _QT_MK_INCLUDED= qt.mk
# Qt versions currently supported by the framework.
_QT_SUPPORTED?= 5
-QT5_VERSION?= 5.14.2
+QT5_VERSION?= 5.15.0
# We accept the Qt version to be passed by either or all of the three mk files.
. if empty(qt_ARGS) && empty(qmake_ARGS) && empty(qt-dist_ARGS)