aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-12-11 18:49:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-12-11 18:49:39 +0000
commit8331a96d1a1685ca3f9328dcfc1ef2e4bc656275 (patch)
treea9056bf2d83a92457df0f835935e00b567081f23 /Mk
parent898132cfd7663567dfc82285aa8ad94e7ef1da3b (diff)
downloadports-8331a96d1a1685ca3f9328dcfc1ef2e4bc656275.tar.gz
ports-8331a96d1a1685ca3f9328dcfc1ef2e4bc656275.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.wx.mk13
1 files changed, 11 insertions, 2 deletions
diff --git a/Mk/bsd.wx.mk b/Mk/bsd.wx.mk
index 21219ed49f28..ff48883ee134 100644
--- a/Mk/bsd.wx.mk
+++ b/Mk/bsd.wx.mk
@@ -131,8 +131,9 @@ _WX_Definitions_Done= yes
_WX_COMPS_ALL= wx contrib python svg
_WX_DEP_TYPES_ALL= build lib run
-_WX_VERS_ALL= 2.4 2.6 2.8
-_WX_VERS_UC_ALL= 2.6 2.8
+_WX_VERS_ALL= 2.4 2.6 2.8 2.9
+_WX_VERS_UC_ALL= 2.6 2.8 2.9
+_WX_VERS_SKIP= 2.9
_WX_VERS_LISTS= WANT_WX_VER WITH_WX_VER _WX_VER_INSTALLED
#
@@ -177,6 +178,10 @@ _WX_FILE_python_2.8= ${PYTHON_SITELIBDIR}/wx-2.8-gtk2${_WX_PYSUFX}/wx/__init__.p
_WX_PORT_svg_2.8= graphics/wxsvg
_WX_LIB_svg_2.8= wxsvg
+# wxgtk 2.9
+_WX_PORT_wx_2.9= x11-toolkits/wxgtk29
+_WX_LIB_wx_2.9= wx_baseu-2.9
+
# Set _WX_SHVER_comp_ver to 0 and _WX_FILE_comp_ver for libs appropiately.
# Set _WX_DEPTYPE_comp_ver for "python" to "run", and others to "lib".
@@ -361,13 +366,17 @@ _WX_VER_MAX:= ${_WX_VER_CHECK:C/.*-([[:digit:]]+(\.[[:digit:]]+)*)/\1/}
. if ${_WX_VER_MIN} == ${_WX_VER_CHECK}
. undef _WX_VER_MIN
. for v in ${_WX_VERS_ALL}
+. if ${_WX_VER_CHECK:C/[-+]//} == ${v} || ${_WX_VERS_SKIP:M${v}} == ""
_WX_VER_MIN?= ${v}
+. endif
. endfor
. endif
# Maximum version not specified.
. if ${_WX_VER_MAX} == ${_WX_VER_CHECK}
. for v in ${_WX_VERS_ALL}
+. if ${_WX_VER_CHECK:C/[-+]//} == ${v} || ${_WX_VERS_SKIP:M${v}} == ""
_WX_VER_MAX= ${v}
+. endif
. endfor
. endif
# Expand versions and add valid ones to each list.