aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-09-27 17:46:39 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-09-27 17:46:39 +0000
commit8833c9bd2b01aae72c851672c84493b94214a016 (patch)
treead45800832662dc62d75b1ed9999450b2dce3a98 /Mk
parentde2c2afc7e5d2e65463648ef4861172c08b8a428 (diff)
downloadports-8833c9bd2b01aae72c851672c84493b94214a016.tar.gz
ports-8833c9bd2b01aae72c851672c84493b94214a016.zip
Print the name of the problematic archive on failed extraction
It is useful when working with a port with a large number of distfiles. In case one of them is failing to extract, the framework would print out its name to ease debugging. Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D25178
Notes
Notes: svn path=/head/; revision=550291
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 7581ea96e62e..aa8c06bc2ded 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3160,6 +3160,7 @@ do-extract: ${EXTRACT_WRKDIR}
@for file in ${EXTRACT_ONLY}; do \
if ! (cd ${EXTRACT_WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$file ${EXTRACT_AFTER_ARGS});\
then \
+ ${ECHO_MSG} "===> Failed to extract \"${_DISTDIR}/$$file\"."; \
exit 1; \
fi; \
done