aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2018-02-08 05:52:06 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2018-02-08 05:52:06 +0000
commiteef0418ce07f5fc26184634d7bf9922799cfc2c8 (patch)
tree13aef3ecf115ec4e921b6f8dd1193638406bc16e /Mk
parented75f066ff76c4fe1e9a956ab1b184add65655c3 (diff)
downloadports-eef0418ce07f5fc26184634d7bf9922799cfc2c8.tar.gz
ports-eef0418ce07f5fc26184634d7bf9922799cfc2c8.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index f317422e4ca0..68e32103478b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4471,9 +4471,11 @@ generate-plist: ${WRKDIR}
@for file in ${PLIST_FILES}; do \
${ECHO_CMD} $${file} | ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} >> ${TMPPLIST}; \
done
+.if !empty(PLIST)
@if [ -f ${PLIST} ]; then \
${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${PLIST} >> ${TMPPLIST}; \
fi
+.endif
.for dir in ${PLIST_DIRS}
@${ECHO_CMD} ${dir} | ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} -e 's,^,@dir ,' >> ${TMPPLIST}