aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-07-26 07:15:08 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-07-26 07:15:08 +0000
commit3c5839ab5a714ecbc3bcd286622acb416ad89ed5 (patch)
tree23a864d3d95e2496f0e12f8f04c91e2a04bc7e4b /Mk
parentc0c2aeaebf5d9ad19d8930a4241226b4325dfca2 (diff)
downloadports-3c5839ab5a714ecbc3bcd286622acb416ad89ed5.tar.gz
ports-3c5839ab5a714ecbc3bcd286622acb416ad89ed5.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/go.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/Uses/go.mk b/Mk/Uses/go.mk
index cfe6cf4faa3b..608e55b86c3f 100644
--- a/Mk/Uses/go.mk
+++ b/Mk/Uses/go.mk
@@ -48,7 +48,7 @@
#
# This variable must not be set by individual ports!
#
-# MAINTAINER: jlaffaye@FreeBSD.org
+# MAINTAINER: dg@syrec.org
.if !defined(_INCLUDE_USES_GO_MK)
_INCLUDE_USES_GO_MK= yes
@@ -117,13 +117,13 @@ post-extract:
.if !target(do-build) && empty(go_ARGS:Mno_targets)
do-build:
(cd ${GO_WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GO_CMD} install ${GO_BUILDFLAGS} ${GO_TARGET})
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GO_CMD} install ${GO_BUILDFLAGS} ${GO_TARGET:S/^${PORTNAME}$/./})
.endif
.if !target(do-install) && empty(go_ARGS:Mno_targets)
do-install:
.for _TARGET in ${GO_TARGET}
- ${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/${_TARGET:T} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/${_TARGET:T:S/^.$/${PORTNAME}/} ${STAGEDIR}${PREFIX}/bin
.endfor
.endif