aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-02-24 13:08:32 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-02-24 13:08:32 +0000
commit432470938d4cca22d8643a36d613aa4616866c14 (patch)
tree7d3c0f7d05bc52368c4311a0a73fc8684265488c /Mk
parentfd5f4b82242d2ef5246d4258e54de660e086320f (diff)
downloadports-432470938d4cca22d8643a36d613aa4616866c14.tar.gz
ports-432470938d4cca22d8643a36d613aa4616866c14.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.kde4.mk21
1 files changed, 11 insertions, 10 deletions
diff --git a/Mk/bsd.kde4.mk b/Mk/bsd.kde4.mk
index 4c534c069c14..54a90afe0c8a 100644
--- a/Mk/bsd.kde4.mk
+++ b/Mk/bsd.kde4.mk
@@ -86,6 +86,17 @@ _USE_KDE4_ALL= akonadi automoc4 baseapps kdebase kdehier kdelibs kdeprefix \
oxygen pimlibs pimruntime pykde4 pykdeuic4 runtime \
sharedmime workspace
+# We need to set it here (and not at the bottom) because PREFIX and
+# NO_MTREE have to be defined in pre-makefile section.
+.if ${USE_KDE4:Mkdeprefix} != ""
+. if ${.MAKEFLAGS:MPREFIX=*} == ""
+PREFIX= ${KDE4_PREFIX}
+. if ${KDE4_PREFIX} != ${LOCALBASE}
+NO_MTREE= yes
+. endif
+. endif
+.endif
+
akonadi_LIB_DEPENDS= akonadiprotocolinternals.1:${PORTSDIR}/databases/akonadi
automoc4_BUILD_DEPENDS= ${LOCALBASE}/bin/automoc4:${PORTSDIR}/devel/automoc4
@@ -97,8 +108,6 @@ kdehier_RUN_DEPENDS= kdehier4>=1:${PORTSDIR}/misc/kdehier4
kdelibs_LIB_DEPENDS= kimproxy.5:${PORTSDIR}/x11/kdelibs4
-kdeprefix_PREFIX= ${KDE4_PREFIX}
-
oxygen_RUN_DEPENDS= ${KDE4_PREFIX}/share/icons/oxygen/index.theme:${PORTSDIR}/x11-themes/kde4-icons-oxygen
pimlibs_LIB_DEPENDS= kpimutils.5:${PORTSDIR}/deskutils/kdepimlibs4
@@ -164,14 +173,6 @@ Kde_Post_Include= bsd.kde4.mk
BUILD_DEPENDS+= ${${component}_BUILD_DEPENDS}
LIB_DEPENDS+= ${${component}_LIB_DEPENDS}
RUN_DEPENDS+= ${${component}_RUN_DEPENDS}
-. if defined(${component}_PREFIX)
-. if ${.MAKEFLAGS:MPREFIX=*}==""
-PREFIX= ${${component}_PREFIX}
-. if ${KDE4_PREFIX} != ${LOCALBASE}
-NO_MTREE= yes
-. endif
-. endif
-. endif
. else
IGNORE= cannot install: Unknown component ${component}
. endif