aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-08-23 14:10:30 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-08-23 14:12:20 +0000
commitea36ef6f67f44bbdfe04643afe7dd3ac69d6c29e (patch)
tree31cf37b4388aab062d8ccd11842f67835606d9d2 /Mk
parent03d5e2defa5f5bec32e2642e248e001300e741cd (diff)
downloadports-ea36ef6f67f44bbdfe04643afe7dd3ac69d6c29e.tar.gz
ports-ea36ef6f67f44bbdfe04643afe7dd3ac69d6c29e.zip
Mk/bsd.port.mk: Add PKG_COMPRESSION_LEVEL user variable
it allows users to set their desired compression level when packaging in make.conf PR: 257427 Suggested by: Trond Endrestol <Trond.Endrestol@ximalas.info>
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index f813ae697972..f8fa7fa4b026 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1002,8 +1002,11 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# ensures periodic output during packaging and
# will help prevent timeouts by build monitors
# PKG_COMPRESSION_FORMAT
-# the compression format used when creating a package, see
+# - the compression format used when creating a package, see
# pkg-create(8) for valid formats
+# PKG_COMPRESSION_LEVEL
+# - the compression level to use when creating a package, see
+# pkg-create(8) for valid values
#
# End of the list of all variables that need to be defined in a port.
# Most port authors should not need to understand anything after this point.
@@ -3486,6 +3489,9 @@ _EXTRA_PACKAGE_TARGET_DEP+= ${WRKDIR_PKGFILE}
.if !target(do-package)
PKG_CREATE_ARGS+= -f ${PKG_COMPRESSION_FORMAT}
+.if defined(PKG_COMPRESSION_LEVEL)
+PKG_CREATE_ARGS+= -l ${PKG_COMPRESSION_LEVEL}
+.endif
PKG_CREATE_ARGS+= -r ${STAGEDIR}
. if defined(PKG_CREATE_VERBOSE)
PKG_CREATE_ARGS+= -v