aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-10-09 01:27:21 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-10-09 01:27:21 +0000
commit3932b94eb7103572080562528b2f935ce2edc4cf (patch)
treeca4139a09e36c5cd9e5c83b10630abc5e27750b3 /Mk
parent35d5a67d37ce4b22103a6aeb635767fc863e0e27 (diff)
downloadports-3932b94eb7103572080562528b2f935ce2edc4cf.tar.gz
ports-3932b94eb7103572080562528b2f935ce2edc4cf.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c50a8ca556c0..39eafd6837d6 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
#-*- mode: Fundamental; tab-width: 4; -*-
# ex:ts=4
#
-# $Id: bsd.port.mk,v 1.291 1998/09/22 23:58:49 asami Exp $
+# $Id: bsd.port.mk,v 1.292 1998/10/06 21:12:14 asami Exp $
# $NetBSD: $
#
# bsd.port.mk - 940820 Jordan K. Hubbard.
@@ -2027,6 +2027,7 @@ generate-plist:
.endif
.endfor
@${SED} ${_sedsubplist} ${PLIST} >> ${TMPPLIST}
+.if !defined(NO_FILTER_SHLIBS)
.if (${PORTOBJFORMAT} == "aout")
@${SED} -e 's,\(/lib.*\.so\.[0-9]*\)$$,\1.0,' ${TMPPLIST} > ${TMPPLIST}.tmp
.else
@@ -2034,6 +2035,7 @@ generate-plist:
.endif
@${MV} -f ${TMPPLIST}.tmp ${TMPPLIST}
.endif
+.endif
${TMPPLIST}:
@cd ${.CURDIR} && ${MAKE} generate-plist