aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-12-04 07:34:27 +0000
committerAde Lovett <ade@FreeBSD.org>2010-12-04 07:34:27 +0000
commit4a8684e352ac6d7260613e6ad3743fabd00eaf7d (patch)
treec1022f7df000935302e4c7f143c5b049290dacc2 /Mk
parent6029732777f019908166457c71136521713b91f7 (diff)
downloadports-4a8684e352ac6d7260613e6ad3743fabd00eaf7d.tar.gz
ports-4a8684e352ac6d7260613e6ad3743fabd00eaf7d.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gnome.mk2
-rw-r--r--Mk/bsd.php.mk2
-rw-r--r--Mk/bsd.port.mk7
3 files changed, 8 insertions, 3 deletions
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index a2fd0dc18ef6..7743670c125a 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -690,7 +690,7 @@ PLIST_SUB+= GTK2_VERSION="${GTK2_VERSION}" \
# Then handle the ltverhack component (it has to be done here, because
# we rely on some bsd.autotools.mk variables, and bsd.autotools.mk is
# included in the post-makefile section).
-.if defined(AUTOTOOL_libtool)
+.if defined(_AUTOTOOL_libtool)
lthacks_CONFIGURE_ENV= ac_cv_path_DOLT_BASH=
lthacks_PRE_PATCH= ${CP} -pf ${LTMAIN} ${WRKDIR}/gnome-ltmain.sh && \
${CP} -pf ${LIBTOOL} ${WRKDIR}/gnome-libtool && \
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index 23af67bee240..db3cd6254bec 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -157,7 +157,7 @@ SUB_LIST+= PHP_EXT_DIR=${PHP_EXT_DIR}
.if defined(USE_PHPIZE) || defined(USE_PHPEXT)
BUILD_DEPENDS+= ${PHPBASE}/bin/phpize:${PORTSDIR}/${PHP_PORT}
GNU_CONFIGURE= yes
-USE_AUTOTOOLS+= autoconf:268:env
+USE_AUTOTOOLS+= autoconf:env
CONFIGURE_ARGS+=--with-php-config=${PHPBASE}/bin/php-config
configure-message: phpize-message do-phpize
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c25e695a157f..ff7d73cc7953 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3748,6 +3748,11 @@ do-patch:
fi
.endif
+.if !target(patch-autotools)
+patch-autotools:
+ @${DO_NADA}
+.endif
+
.if !target(run-autotools)
run-autotools:
@${DO_NADA}
@@ -4412,7 +4417,7 @@ _EXTRACT_SEQ= check-build-conflicts extract-message checksum extract-depends \
post-extract post-extract-script
_PATCH_DEP= extract
_PATCH_SEQ= ask-license patch-message patch-depends patch-dos2unix pre-patch \
- pre-patch-script do-patch post-patch post-patch-script
+ pre-patch-script do-patch patch-autotools post-patch post-patch-script
_CONFIGURE_DEP= patch
_CONFIGURE_SEQ= build-depends lib-depends configure-message \
pre-configure pre-configure-script \