aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-10-10 02:58:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-10-10 02:58:43 +0000
commit57f29e80f17c7124f456aec36568c396d815a760 (patch)
treef10e70a888bae846885bcbb8b1394ed8b1d32fba /Mk
parentf42a9340f9f9742d038d9205e1341a5d0290b4f6 (diff)
downloadports-57f29e80f17c7124f456aec36568c396d815a760.tar.gz
ports-57f29e80f17c7124f456aec36568c396d815a760.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 76ebc74c0c50..06749566bb68 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -85,7 +85,7 @@ MOZILLA_VER?= ${PORTVERSION}
MOZILLA_BIN?= ${PORTNAME}-bin
MOZILLA_EXEC_NAME?=${MOZILLA}
MOZ_RPATH?= ${MOZILLA}
-USES+= cpe compiler:c++11-lang gmake iconv perl5 pkgconfig \
+USES+= cpe gmake iconv perl5 pkgconfig \
python:2.7,build desktop-file-utils
CPE_VENDOR?=mozilla
USE_PERL5= build
@@ -96,9 +96,11 @@ BUNDLE_LIBS= yes
.endif
# call to implicitly-deleted copy constructor of 'mozilla::WidevineVideoFrame'
-. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000019 && ${MOZILLA_VER:R:R} >= 49
-# XXX USES=compiler:c++11-lib cannot be used due to ports/208538
-USE_GCC= 5+
+.if ${MOZILLA_VER:R:R} >= 49
+USES+= compiler:c++14-lang
+FAVORITE_COMPILER= gcc # c++14-lib
+.else
+USES+= compiler:c++11-lang
.endif
MOZILLA_SUFX?= none