aboutsummaryrefslogtreecommitdiff
path: root/Tools
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-05-20 07:19:07 +0000
committerWill Andrews <will@FreeBSD.org>2002-05-20 07:19:07 +0000
commit13f0dec1741cb3756b4c4b795592245ada82d9c5 (patch)
treef88ad0b7698c48c29b75cc3e6d64124c218cb1cb /Tools
parent91a4623523a4d3ef3d846eca24d075c2a7b42329 (diff)
downloadports-13f0dec1741cb3756b4c4b795592245ada82d9c5.tar.gz
ports-13f0dec1741cb3756b4c4b795592245ada82d9c5.zip
Notes
Diffstat (limited to 'Tools')
-rw-r--r--Tools/scripts/release/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/Tools/scripts/release/Makefile b/Tools/scripts/release/Makefile
new file mode 100644
index 000000000000..e899f277092f
--- /dev/null
+++ b/Tools/scripts/release/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+#
+# The purpose of this Makefile is to setup a standardized environment
+# for making package splits. Basically, for each split the organization
+# looks like this:
+#
+# src/release/scripts
+# ports/Tools/scripts/release
+# RELEASE (e.g. 4.6-RELEASE or 4.6-RC1)
+# symlinks to scripts required
+# directories used by scripts
+# config files
+#
+# The desire is to provide the scripts with the environment they
+# expect while preserving the ability to cvs update them.
+
+RELEASE?=
+SRCSCRIPTDIR?= /usr/src/release/scripts
+SRCSCRIPTS= print-cdrom-packages.sh
+PORTSCRIPTS!= echo *.pl *.sh
+FORCE?= no
+PWD!= pwd
+
+all:
+ @if [ -z "${RELEASE}" ]; then \
+ echo "Release must be specified, i.e.:"; \
+ echo " make RELEASE=4.6-RELEASE"; \
+ exit 1; \
+ fi
+ @if [ -d "${RELEASE}" -a "${FORCE}" = "no" ]; then \
+ echo "The release directory ${RELEASE} already exists."; \
+ echo "To force setup type:"; \
+ echo " make RELEASE=${RELEASE} FORCE=yes"; \
+ exit 1; \
+ fi
+ # We *could* use mkdir -p, but being explicit helps.
+ mkdir ${RELEASE}
+.for SUBDIR in disc1 disc3 gen
+ mkdir ${RELEASE}/${SUBDIR}
+.endfor
+.for SCRIPT in ${PORTSCRIPTS}
+ cd ${RELEASE} && ln -s ../${SCRIPT} .
+.endfor
+.for SRCSCRIPT in ${SRCSCRIPTS}
+ cd ${RELEASE} && ln -s ${SRCSCRIPTS}/${SRCSCRIPT} .
+ @echo "Done."
+.endfor
+ cd ${RELEASE} && ln -s ../config .