aboutsummaryrefslogtreecommitdiff
path: root/Tools
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2017-04-30 17:45:31 +0000
committerLarry Rosenman <ler@FreeBSD.org>2017-04-30 17:45:31 +0000
commit62de852b7f85501779c93ba57e40137901d99252 (patch)
treee6f25d0f5b0d5499a0212a00e8efde27caef9349 /Tools
parentbf754897d7af2eb86fc2a63fde775975b707af0f (diff)
downloadports-62de852b7f85501779c93ba57e40137901d99252.tar.gz
ports-62de852b7f85501779c93ba57e40137901d99252.zip
Update Tools/scripts/rmport to ignore commented out EXPIRATION_DATE lines
Reviewed by: crees (maintainer) Approved by: rene (portmgr, mentor), adamw (portmgr, mentor), crees (maintainer) Differential Revision: https://reviews.freebsd.org/D10548
Notes
Notes: svn path=/head/; revision=439833
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/scripts/rmport2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tools/scripts/rmport b/Tools/scripts/rmport
index 92e4f2cb6376..8da23c47071d 100755
--- a/Tools/scripts/rmport
+++ b/Tools/scripts/rmport
@@ -109,7 +109,7 @@ find_expired()
EXPVAR=EXPIRATION_DATE
find -H ${PORTSDIR} -mindepth 3 -maxdepth 3 -name "Makefile*" \
- |xargs grep -H ${EXPVAR} \
+ |xargs grep -H "^[^#]*${EXPVAR}" \
|sed -E "s|${PORTSDIR}/?([^/]+/[^/]+)/Makefile:${EXPVAR}=[[:space:]]*([0-9-]{10})$|\2 \1|g" \
|perl -ne "if ((substr(\$_, 0, 10) cmp '${TODAY}') <= 0) { print(\$_); }" \
|while read expdate catport ; do \