aboutsummaryrefslogtreecommitdiff
path: root/Tools
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-14 06:13:10 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-14 06:13:10 +0000
commit9a38c1b8b941b887d83c3dc199bb0e2ae655b7f7 (patch)
tree00d861d72c934c1b1bcf4ffdbd53a1069213d579 /Tools
parentc4e4ab92e20d0b4b939c8e869dea02e7d03a7976 (diff)
downloadports-9a38c1b8b941b887d83c3dc199bb0e2ae655b7f7.tar.gz
ports-9a38c1b8b941b887d83c3dc199bb0e2ae655b7f7.zip
Notes
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/scripts/notconnected43
1 files changed, 43 insertions, 0 deletions
diff --git a/Tools/scripts/notconnected b/Tools/scripts/notconnected
new file mode 100755
index 000000000000..66bcae484190
--- /dev/null
+++ b/Tools/scripts/notconnected
@@ -0,0 +1,43 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# MAINTAINER= pgollucci@FreeBSD.org
+# all committers may commit to this file without approval
+
+PATH=/rescue:$PATH
+
+if [ -z "$PORTSDIR" ]; then
+ PORTSDIR=/usr/ports
+fi
+
+echo "****************** No entry for dir in category Makefile"
+#### dir -> Makefile
+cd $PORTSDIR
+
+ports=$(find $PORTSDIR -type d -depth 2 | egrep -v 'CVS|.git|Tools')
+for port in $ports; do
+ cat=$(echo $port |awk -F'/' '{print $1}')
+ portname=$(echo $port |awk -F'/' '{print $2}')
+
+ rc=$(grep -c " $portname$" $PORTSDIR/$cat/Makefile)
+ if [ $rc -ne 1 ]; then
+ echo "$cat/$portname"
+ fi
+done
+
+echo "***************** No corresponding dir for category Makefile entry"
+#### Makefile -> dir
+cd $PORTSDIR
+categories=$(ls -1d * |grep -v [A-Z] |grep -v distfiles)
+
+for cat in $categories; do
+ cd $PORTSDIR/$cat
+ ports=$(grep SUBDIR Makefile |awk '{print $3}')
+ for port in $ports; do
+ if [ ! -d $port ]; then
+ echo "$cat/$port"
+ fi
+ done
+done
+