aboutsummaryrefslogtreecommitdiff
path: root/Tools
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:33:29 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:33:29 +0000
commit30c4ca57841f7ed00f4b8bd08e9fb77a99ea03c2 (patch)
treec68f282f056cada60fad8fc282c20f9ffdbfd0ee /Tools
parent9d8e2a3c3d58395efca06a2610bf09873ae61918 (diff)
downloadports-30c4ca57841f7ed00f4b8bd08e9fb77a99ea03c2.tar.gz
ports-30c4ca57841f7ed00f4b8bd08e9fb77a99ea03c2.zip
Generic FLAVORS work.
- Enable FLAVORS. - Make make describe flavors aware. - Add a qa check for unique package names amongst flavors. - Make MOVEDlint understand flavors. - Add a bit of sanity check to make sure FLAVORS stay lowercase. - Various fixes. Reviewed by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12577
Notes
Notes: svn path=/head/; revision=455205
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/scripts/MOVEDlint.awk31
1 files changed, 30 insertions, 1 deletions
diff --git a/Tools/scripts/MOVEDlint.awk b/Tools/scripts/MOVEDlint.awk
index e2445ba44f41..60de5f90dd52 100755
--- a/Tools/scripts/MOVEDlint.awk
+++ b/Tools/scripts/MOVEDlint.awk
@@ -80,15 +80,44 @@ $3 !~ /^20[0-3][0-9]-[01][0-9]-[0-3][0-9]$/ {
}
lastdate = $3
+ from_flavor=""
+ if ($1 ~ "@") {
+ from_flavor=$1
+ sub("@.*", "", $1)
+ sub(".*@", "", from_flavor)
+ }
+
if (system("test -f " portsdir "/" $1 "/Makefile")) {
delete missing[$1]
} else {
- printf "%5d: %s must be marked as resurrected\n", NR, $1 | sort
+ if (from_flavor != "") {
+ if (!system("test \"" from_flavor "\" = \"`make -C " portsdir "/" $1 " -VFLAVORS:M" from_flavor "`\"")) {
+ printf "%5d: %s still has the %s flavor\n", NR, $1, from_flavor | sort
+ }
+ # No else because the port is there but does not have the flavor,
+ # so it should be ok.
+ } else {
+ printf "%5d: %s must be marked as resurrected\n", NR, $1 | sort
+ }
}
if ($2) {
+ to_flavor=""
+ if ($2 ~ "@") {
+ to_flavor=$2
+ sub("@.*", "", $2)
+ sub(".*@", "", to_flavor)
+ }
+
if (system("test -f " portsdir "/" $2 "/Makefile"))
missing[$2] = NR
+ else
+ if (to_flavor != "") {
+ if (system("test \"" to_flavor "\" = \"`make -C " portsdir "/" $2 " -VFLAVORS:M" to_flavor "`\"")) {
+ printf "%5d: %s does not have the %s flavor\n", NR, $2, to_flavor | sort
+ error[NR] = 1
+ }
+ }
}
# Produces too many false positives