aboutsummaryrefslogtreecommitdiff
path: root/Tools
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-10 11:59:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-10 11:59:28 +0000
commit4bcdfb868553fb18cc65f502de4f3039fb501b7b (patch)
treecba041477710bce72176d7a4df420846c3971a10 /Tools
parent0f100e6d8d97a30db96ff29630e13b6b915b8183 (diff)
downloadports-4bcdfb868553fb18cc65f502de4f3039fb501b7b.tar.gz
ports-4bcdfb868553fb18cc65f502de4f3039fb501b7b.zip
Cleanup resurrected processing.
There is no need to have a resurrected array, it is only used once, so move the resurrected printf where it belongs. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=453895
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/scripts/MOVEDlint.awk8
1 files changed, 1 insertions, 7 deletions
diff --git a/Tools/scripts/MOVEDlint.awk b/Tools/scripts/MOVEDlint.awk
index 0f0f16277ff2..8d8ce294f251 100755
--- a/Tools/scripts/MOVEDlint.awk
+++ b/Tools/scripts/MOVEDlint.awk
@@ -83,14 +83,12 @@ $3 !~ /^20[0-3][0-9]-[01][0-9]-[0-3][0-9]$/ {
if (system("test -f " portsdir "/" $1 "/Makefile")) {
delete missing[$1]
} else {
- resurrected[$1] = NR
+ printf "%5d: %s must be marked as resurrected\n", NR, port | sort
}
if ($2) {
if (system("test -f " portsdir "/" $2 "/Makefile"))
missing[$2] = NR
-# else
-# delete resurrected[$2]
}
# Produces too many false positives
@@ -106,10 +104,6 @@ $3 !~ /^20[0-3][0-9]-[01][0-9]-[0-3][0-9]$/ {
}
END {
- for (port in resurrected) {
- printf "%5d: %s must be marked as resurrected\n", resurrected[port], port | sort
- }
-
for (port in missing) {
printf "%5d: %s not found\n", missing[port], port | sort
error[missing[port]] = 1