aboutsummaryrefslogtreecommitdiff
path: root/accessibility/at-spi
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /accessibility/at-spi
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
downloadports-798e9bed2a389dce8a970e15b68176fd49f442db.tar.gz
ports-798e9bed2a389dce8a970e15b68176fd49f442db.zip
Notes
Diffstat (limited to 'accessibility/at-spi')
-rw-r--r--accessibility/at-spi/Makefile13
-rw-r--r--accessibility/at-spi/distinfo6
-rw-r--r--accessibility/at-spi/files/patch-docs_reference_idl_Makefile.in11
-rw-r--r--accessibility/at-spi/files/patch-libspi_Makefile.in11
-rw-r--r--accessibility/at-spi/files/patch-registryd_Makefile.in11
-rw-r--r--accessibility/at-spi/pkg-plist180
6 files changed, 200 insertions, 32 deletions
diff --git a/accessibility/at-spi/Makefile b/accessibility/at-spi/Makefile
index ab46c80bf15f..c1207d4ada51 100644
--- a/accessibility/at-spi/Makefile
+++ b/accessibility/at-spi/Makefile
@@ -3,31 +3,36 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/accessibility/at-spi/Makefile,v 1.43 2006/04/13 07:52:28 bland Exp $
#
PORTNAME= at-spi
-PORTVERSION= 1.6.6
-PORTREVISION= 2
+PORTVERSION= 1.7.7
CATEGORIES= accessibility x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.6
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= An Assistive Technology Service Provider Interface
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier intltool gail libbonobo \
intlhack
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-USE_REINPLACE= yes
CONFIGURE_ARGS= --enable-static
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+
+post-extract:
+ @${RM} -f ${WRKSRC}/registryd/Accessibility_Registry.server
+
post-patch:
@${REINPLACE_CMD} -e "/^SUBDIRS =/s/test//" ${WRKSRC}/Makefile.in
diff --git a/accessibility/at-spi/distinfo b/accessibility/at-spi/distinfo
index 1155e21ca64e..8faba5778802 100644
--- a/accessibility/at-spi/distinfo
+++ b/accessibility/at-spi/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/at-spi-1.6.6.tar.bz2) = 9669ee9e3633ffb43a70795edd748e4d
-SHA256 (gnome2/at-spi-1.6.6.tar.bz2) = e80e6e93923bb00d2beb5409bf532d4ff3a3f76afaa41dda9cdd336729e42020
-SIZE (gnome2/at-spi-1.6.6.tar.bz2) = 541611
+MD5 (gnome2/at-spi-1.7.7.tar.bz2) = 2988cd21d9f292fd404a8c532fe2723d
+SHA256 (gnome2/at-spi-1.7.7.tar.bz2) = 8e5a5a9be3e3c26068b98fbcd37e44a6c377b1d8f97735339e8dd1215b506ad6
+SIZE (gnome2/at-spi-1.7.7.tar.bz2) = 696704
diff --git a/accessibility/at-spi/files/patch-docs_reference_idl_Makefile.in b/accessibility/at-spi/files/patch-docs_reference_idl_Makefile.in
new file mode 100644
index 000000000000..f8b41ab8c214
--- /dev/null
+++ b/accessibility/at-spi/files/patch-docs_reference_idl_Makefile.in
@@ -0,0 +1,11 @@
+--- docs/reference/idl/Makefile.in.orig Fri Mar 31 17:43:05 2006
++++ docs/reference/idl/Makefile.in Fri Mar 31 17:43:28 2006
+@@ -233,7 +233,7 @@ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ doxygen_configfile = Doxyfile
+ EXTRA_DIST = Doxyfile README html
+-referencetopdir = $(datadir)/doc/at-spi-$(VERSION)/reference
++referencetopdir = $(prefix)/share/doc/at-spi-$(VERSION)/reference
+ referencedir = $(referencetopdir)/html
+ all: all-am
+
diff --git a/accessibility/at-spi/files/patch-libspi_Makefile.in b/accessibility/at-spi/files/patch-libspi_Makefile.in
deleted file mode 100644
index cfb55a212a86..000000000000
--- a/accessibility/at-spi/files/patch-libspi_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- libspi/Makefile.in.orig Fri May 2 13:36:07 2003
-+++ libspi/Makefile.in Fri May 2 13:36:37 2003
-@@ -539,7 +539,7 @@
- mostlyclean distclean maintainer-clean
-
-
--$(top_srcdir)/libspi/accessible.c $(top_srcdir)/libspi/base.h $(top_srcdir)/libspi/keystrokelistener.h $(top_srcdir)/libspi/libspi.h $(top_srcdir)/libspi/listener.h $(top_srcdir)/libspi/remoteobject.h : Accessibility.h
-+accessible.c base.h keystrokelistener.h libspi.h listener.h remoteobject.h : Accessibility.h
-
- $(IDL_OUT) Accessibility-imodule.c : $(IDL_DEPS) $(ORBIT_IDL)
- $(ORBIT_IDL) -D__ACCESSIBILITY_COMPILATION__ $(IDLFLAGS) $(top_srcdir)/idl/Accessibility.idl
diff --git a/accessibility/at-spi/files/patch-registryd_Makefile.in b/accessibility/at-spi/files/patch-registryd_Makefile.in
deleted file mode 100644
index 7729e9da1400..000000000000
--- a/accessibility/at-spi/files/patch-registryd_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- registryd/Makefile.in.orig Fri Aug 8 12:15:34 2003
-+++ registryd/Makefile.in Fri Aug 8 12:20:05 2003
-@@ -150,7 +150,7 @@
- at_spi_registryd_SOURCES = desktop.c desktop.h deviceeventcontroller.c deviceeventcontroller.h registry-main.c registry.c registry.h
-
-
--LDADD = $(top_builddir)/libspi/libspi.la $(X_LIBS) $(XTST_LIBS) $(XEVIE_LIBS) $(REGISTRYD_LIBS)
-+LDADD = -L$(top_builddir)/libspi/.libs $(top_builddir)/libspi/libspi.la $(X_LIBS) $(XTST_LIBS) $(XEVIE_LIBS) $(REGISTRYD_LIBS)
-
- serverinfodir = $(prefix)/libdata/bonobo/servers
- serverinfo_DATA = Accessibility_Registry.server
diff --git a/accessibility/at-spi/pkg-plist b/accessibility/at-spi/pkg-plist
index f87187c9c458..2b256a37de20 100644
--- a/accessibility/at-spi/pkg-plist
+++ b/accessibility/at-spi/pkg-plist
@@ -29,6 +29,9 @@ include/at-spi-1.0/libspi/text.h
include/at-spi-1.0/libspi/value.h
include/at-spi-1.0/login-helper/Accessibility_LoginHelper.h
include/at-spi-1.0/login-helper/login-helper.h
+lib/gtk-2.0/modules/libatk-bridge.a
+lib/gtk-2.0/modules/libatk-bridge.la
+lib/gtk-2.0/modules/libatk-bridge.so
lib/libcspi.a
lib/libcspi.la
lib/libcspi.so
@@ -41,9 +44,6 @@ lib/libspi.a
lib/libspi.la
lib/libspi.so
lib/libspi.so.10
-lib/gtk-2.0/modules/libatk-bridge.a
-lib/gtk-2.0/modules/libatk-bridge.la
-lib/gtk-2.0/modules/libatk-bridge.so
lib/orbit-2.0/Accessibility_LoginHelper_module.a
lib/orbit-2.0/Accessibility_LoginHelper_module.la
lib/orbit-2.0/Accessibility_LoginHelper_module.so
@@ -55,6 +55,102 @@ libdata/pkgconfig/cspi-1.0.pc
libdata/pkgconfig/libloginhelper-1.0.pc
libdata/pkgconfig/libspi-1.0.pc
libexec/at-spi-registryd
+%%DOCSDIR%%/reference/html/Accessibility_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Accessible_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Accessible_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Action_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Action_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Application_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Application_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Component_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Component_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Desktop_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Desktop_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__EditableText_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__EditableText_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Event_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Event_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Hyperlink_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Hyperlink_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Hypertext_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Hypertext_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Image_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Image_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__LoginHelper_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__LoginHelper_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Registry_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Registry_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Relation_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Relation_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Role_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Role_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Selection_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Selection_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Selector_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Selector_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__State_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__State_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__StreamableContent_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__StreamableContent_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Table_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Table_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Text_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Text_8idl.html
+%%DOCSDIR%%/reference/html/Accessibility__Value_8idl-source.html
+%%DOCSDIR%%/reference/html/Accessibility__Value_8idl.html
+%%DOCSDIR%%/reference/html/annotated.html
+%%DOCSDIR%%/reference/html/doxygen.css
+%%DOCSDIR%%/reference/html/doxygen.png
+%%DOCSDIR%%/reference/html/exceptionAccessibility_1_1StreamableContent_1_1IOError.html
+%%DOCSDIR%%/reference/html/exceptionAccessibility_1_1StreamableContent_1_1NoPermission.html
+%%DOCSDIR%%/reference/html/exceptionAccessibility_1_1StreamableContent_1_1NotSupported.html
+%%DOCSDIR%%/reference/html/files.html
+%%DOCSDIR%%/reference/html/functions.html
+%%DOCSDIR%%/reference/html/hierarchy.html
+%%DOCSDIR%%/reference/html/index.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Accessible.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Accessible.png
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Action.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Application.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Application.png
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1CommandListener.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Component.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Desktop.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Desktop.png
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1DeviceEventController.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1DeviceEventListener.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1EditableText.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1EditableText.png
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1EventListener.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1EventListener.png
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Hyperlink.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Hypertext.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Image.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1LoginHelper.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Registry.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Registry.png
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Relation.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Selection.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Selector.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1StateSet.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1StreamableContent.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Table.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Text.html
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Text.png
+%%DOCSDIR%%/reference/html/interfaceAccessibility_1_1Value.html
+%%DOCSDIR%%/reference/html/namespaceAccessibility.html
+%%DOCSDIR%%/reference/html/namespacemembers.html
+%%DOCSDIR%%/reference/html/namespaces.html
+%%DOCSDIR%%/reference/html/structAccessibility_1_1BoundingBox.html
+%%DOCSDIR%%/reference/html/structAccessibility_1_1Command.html
+%%DOCSDIR%%/reference/html/structAccessibility_1_1DeviceEvent.html
+%%DOCSDIR%%/reference/html/structAccessibility_1_1Event.html
+%%DOCSDIR%%/reference/html/structAccessibility_1_1EventDetails.html
+%%DOCSDIR%%/reference/html/structAccessibility_1_1EventListenerMode.html
+%%DOCSDIR%%/reference/html/structAccessibility_1_1KeyDefinition.html
+%%DOCSDIR%%/reference/html/structAccessibility_1_1LoginHelper_1_1WindowInfo.html
+%%DOCSDIR%%/reference/html/structAccessibility_1_1Text_1_1Range.html
share/doc/at-spi-cspi/at-spi-cspi-Accessible-Objects.html
share/doc/at-spi-cspi/at-spi-cspi-AccessibleAction-Interface.html
share/doc/at-spi-cspi/at-spi-cspi-AccessibleApplication-API.html
@@ -73,6 +169,7 @@ share/doc/at-spi-cspi/at-spi-cspi-Registry-queries.html
share/doc/at-spi-cspi/at-spi-cspi-SPI-main-loop-and-initialization.html
share/doc/at-spi-cspi/at-spi-cspi-State-and-StateSets.html
share/doc/at-spi-cspi/at-spi-cspi.devhelp
+share/doc/at-spi-cspi/at-spi-cspi.devhelp2
share/doc/at-spi-cspi/ch05.html
share/doc/at-spi-cspi/home.png
share/doc/at-spi-cspi/index.html
@@ -101,13 +198,90 @@ share/gnome/idl/at-spi-1.0/Accessibility_Registry.idl
share/gnome/idl/at-spi-1.0/Accessibility_Relation.idl
share/gnome/idl/at-spi-1.0/Accessibility_Role.idl
share/gnome/idl/at-spi-1.0/Accessibility_Selection.idl
+share/gnome/idl/at-spi-1.0/Accessibility_Selector.idl
share/gnome/idl/at-spi-1.0/Accessibility_State.idl
share/gnome/idl/at-spi-1.0/Accessibility_StreamableContent.idl
share/gnome/idl/at-spi-1.0/Accessibility_Table.idl
share/gnome/idl/at-spi-1.0/Accessibility_Text.idl
share/gnome/idl/at-spi-1.0/Accessibility_Value.idl
+share/locale/ar/LC_MESSAGES/at-spi.mo
+share/locale/az/LC_MESSAGES/at-spi.mo
+share/locale/be/LC_MESSAGES/at-spi.mo
+share/locale/bg/LC_MESSAGES/at-spi.mo
+share/locale/bn/LC_MESSAGES/at-spi.mo
+share/locale/bs/LC_MESSAGES/at-spi.mo
+share/locale/ca/LC_MESSAGES/at-spi.mo
+share/locale/cs/LC_MESSAGES/at-spi.mo
+share/locale/cy/LC_MESSAGES/at-spi.mo
+share/locale/da/LC_MESSAGES/at-spi.mo
+share/locale/de/LC_MESSAGES/at-spi.mo
+share/locale/dz/LC_MESSAGES/at-spi.mo
+share/locale/el/LC_MESSAGES/at-spi.mo
+share/locale/en_CA/LC_MESSAGES/at-spi.mo
+share/locale/en_GB/LC_MESSAGES/at-spi.mo
+share/locale/eo/LC_MESSAGES/at-spi.mo
+share/locale/es/LC_MESSAGES/at-spi.mo
+share/locale/et/LC_MESSAGES/at-spi.mo
+share/locale/eu/LC_MESSAGES/at-spi.mo
+share/locale/fa/LC_MESSAGES/at-spi.mo
+share/locale/fi/LC_MESSAGES/at-spi.mo
+share/locale/fr/LC_MESSAGES/at-spi.mo
+share/locale/gl/LC_MESSAGES/at-spi.mo
+share/locale/gu/LC_MESSAGES/at-spi.mo
+share/locale/he/LC_MESSAGES/at-spi.mo
+share/locale/hi/LC_MESSAGES/at-spi.mo
+share/locale/hr/LC_MESSAGES/at-spi.mo
+share/locale/hu/LC_MESSAGES/at-spi.mo
+share/locale/id/LC_MESSAGES/at-spi.mo
+share/locale/is/LC_MESSAGES/at-spi.mo
+share/locale/it/LC_MESSAGES/at-spi.mo
+share/locale/ja/LC_MESSAGES/at-spi.mo
+share/locale/ka/LC_MESSAGES/at-spi.mo
+share/locale/ko/LC_MESSAGES/at-spi.mo
+share/locale/lt/LC_MESSAGES/at-spi.mo
+share/locale/mn/LC_MESSAGES/at-spi.mo
+share/locale/mr/LC_MESSAGES/at-spi.mo
+share/locale/ms/LC_MESSAGES/at-spi.mo
+share/locale/nb/LC_MESSAGES/at-spi.mo
+share/locale/ne/LC_MESSAGES/at-spi.mo
+share/locale/nl/LC_MESSAGES/at-spi.mo
+share/locale/nn/LC_MESSAGES/at-spi.mo
+share/locale/no/LC_MESSAGES/at-spi.mo
+share/locale/or/LC_MESSAGES/at-spi.mo
+share/locale/pa/LC_MESSAGES/at-spi.mo
+share/locale/pl/LC_MESSAGES/at-spi.mo
+share/locale/pt/LC_MESSAGES/at-spi.mo
+share/locale/pt_BR/LC_MESSAGES/at-spi.mo
+share/locale/ro/LC_MESSAGES/at-spi.mo
+share/locale/ru/LC_MESSAGES/at-spi.mo
+share/locale/rw/LC_MESSAGES/at-spi.mo
+share/locale/sk/LC_MESSAGES/at-spi.mo
+share/locale/sl/LC_MESSAGES/at-spi.mo
+share/locale/sq/LC_MESSAGES/at-spi.mo
+share/locale/sr/LC_MESSAGES/at-spi.mo
+share/locale/sr@Latn/LC_MESSAGES/at-spi.mo
+share/locale/sr@ije/LC_MESSAGES/at-spi.mo
+share/locale/sv/LC_MESSAGES/at-spi.mo
+share/locale/th/LC_MESSAGES/at-spi.mo
+share/locale/ug/LC_MESSAGES/at-spi.mo
+share/locale/uk/LC_MESSAGES/at-spi.mo
+share/locale/vi/LC_MESSAGES/at-spi.mo
+share/locale/wa/LC_MESSAGES/at-spi.mo
+share/locale/xh/LC_MESSAGES/at-spi.mo
+share/locale/zh_CN/LC_MESSAGES/at-spi.mo
+share/locale/zh_HK/LC_MESSAGES/at-spi.mo
+share/locale/zh_TW/LC_MESSAGES/at-spi.mo
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
@dirrm share/gnome/idl/at-spi-1.0
@dirrm share/doc/at-spi-cspi
+@dirrm %%DOCSDIR%%/reference/html
+@dirrm %%DOCSDIR%%/reference
+@dirrm %%DOCSDIR%%
@dirrm lib/orbit-2.0
@dirrm include/at-spi-1.0/login-helper
@dirrm include/at-spi-1.0/libspi