aboutsummaryrefslogtreecommitdiff
path: root/accessibility/dasher/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 09:51:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 09:51:36 +0000
commite04596d72eed49b08af4f018be6a29a86e7dca5f (patch)
tree0a9655f722e7d7d6ba93044e8f28d02393883bf3 /accessibility/dasher/Makefile
parentc37688e9a02127e47c98de989f2df1c57767650e (diff)
downloadports-e04596d72eed49b08af4f018be6a29a86e7dca5f.tar.gz
ports-e04596d72eed49b08af4f018be6a29a86e7dca5f.zip
Notes
Diffstat (limited to 'accessibility/dasher/Makefile')
-rw-r--r--accessibility/dasher/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index 107805c07813..e22822999145 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -14,15 +14,13 @@ MAINTAINER= lewiz@compsoc.man.ac.uk
COMMENT= Information efficient text-entry interface
BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
-LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg
+LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg
RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
-NO_STAGE= yes
USE_BZIP2= yes
-USES= gettext gmake pkgconfig
-USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi \
+USES= gettext gmake pathfix pkgconfig
+USE_GNOME= gnomeprefix intlhack gnomehier libgnomeui atspi \
libwnck gnomedocutils
-WANT_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
@@ -30,14 +28,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= dasher.schemas
-MAN1= dasher.1
-.include <bsd.port.pre.mk>
-
-#.if ${HAVE_GNOME:Mgnomespeech}!=""
-#USE_GNOME+= gnomespeech
-#CONFIGURE_ARGS+=--enable-speech
-#.endif
CONFIGURE_ARGS+= --disable-speech
post-patch:
@@ -47,4 +38,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|__gnu_cxx::lldiv|lldiv|' \
${WRKSRC}/Src/DasherCore/DasherViewSquare.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>