aboutsummaryrefslogtreecommitdiff
path: root/accessibility/dasher
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /accessibility/dasher
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'accessibility/dasher')
-rw-r--r--accessibility/dasher/Makefile7
-rw-r--r--accessibility/dasher/distinfo4
-rw-r--r--accessibility/dasher/files/patch-Src_Gtk2_speech.cc15
-rw-r--r--accessibility/dasher/pkg-plist77
4 files changed, 84 insertions, 19 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index c93d7ee10dfe..8ada000f1a79 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dasher
-PORTVERSION= 3.2.11
-PORTREVISION= 4
+PORTVERSION= 3.2.15
CATEGORIES= accessibility editors x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/3.2
@@ -22,9 +21,11 @@ RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi
+USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi \
+ libwnck
WANT_GNOME= yes
USE_LIBTOOL_VER=15
+INSTALLS_OMF= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/accessibility/dasher/distinfo b/accessibility/dasher/distinfo
index 9c279f0959c9..02812ef26e43 100644
--- a/accessibility/dasher/distinfo
+++ b/accessibility/dasher/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/dasher-3.2.11.tar.bz2) = f3180d8ec786c1ea158cc5ac0894856c
-SIZE (gnome2/dasher-3.2.11.tar.bz2) = 2651970
+MD5 (gnome2/dasher-3.2.15.tar.bz2) = a3fa85e32c94c69476e12ecba7d257e7
+SIZE (gnome2/dasher-3.2.15.tar.bz2) = 8981223
diff --git a/accessibility/dasher/files/patch-Src_Gtk2_speech.cc b/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
index 93031e47f2c4..05d3c3b835fd 100644
--- a/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
+++ b/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
@@ -1,20 +1,11 @@
---- Src/Gtk2/speech.cc.orig Fri Jul 30 15:28:41 2004
-+++ Src/Gtk2/speech.cc Sun Feb 13 20:15:46 2005
-@@ -46,7 +46,7 @@
-
- voices = GNOME_Speech_SynthesisDriver_getAllVoices (rv, &ev);
-
-- if (voices==NULL || BONOBO_EX (&ev)) {
-+ if (voices==NULL || BONOBO_EX (&ev) || voices->_length==0) {
- printf(_("Unable to initialize voices"));
- speaker=NULL;
- return;
+--- Src/Gtk2/speech.cc.orig Fri Sep 17 06:53:53 2004
++++ Src/Gtk2/speech.cc Sat Feb 26 01:00:12 2005
@@ -78,7 +78,8 @@
void teardown_speech() {
bonobo_object_release_unref (speaker, NULL);
- CORBA_free (voices);
-+ if (voices != NULL && voices->_length != 0)
++ if (voices != NULL && !BONOBO_EX (&ev) && voices->_length != 0)
+ CORBA_free (voices);
CORBA_exception_free (&ev);
diff --git a/accessibility/dasher/pkg-plist b/accessibility/dasher/pkg-plist
index 2d6c939517fc..1be84180bf55 100644
--- a/accessibility/dasher/pkg-plist
+++ b/accessibility/dasher/pkg-plist
@@ -1,6 +1,8 @@
bin/dasher
share/gnome/applications/dasher.desktop
share/gnome/dasher/alphabet.Armenian.xml
+share/gnome/dasher/alphabet.Assamese.xml
+share/gnome/dasher/alphabet.Austen.xml
share/gnome/dasher/alphabet.Azerbaijani.xml
share/gnome/dasher/alphabet.Belarusian.xml
share/gnome/dasher/alphabet.Bengali.xml
@@ -9,23 +11,37 @@ share/gnome/dasher/alphabet.Esperanto.xml
share/gnome/dasher/alphabet.Estonian.xml
share/gnome/dasher/alphabet.Filipino.xml
share/gnome/dasher/alphabet.Greek.xml
+share/gnome/dasher/alphabet.Gujarati.xml
share/gnome/dasher/alphabet.Hebrew.xml
+share/gnome/dasher/alphabet.Hindi.xml
share/gnome/dasher/alphabet.Icelandic.xml
share/gnome/dasher/alphabet.Igbo.xml
share/gnome/dasher/alphabet.Indonesian.xml
share/gnome/dasher/alphabet.IrishGaelic.xml
+share/gnome/dasher/alphabet.Japanese.xml
+share/gnome/dasher/alphabet.Joyo.xml
+share/gnome/dasher/alphabet.Joyo2.xml
+share/gnome/dasher/alphabet.Kannada.xml
+share/gnome/dasher/alphabet.Katakana.xml
share/gnome/dasher/alphabet.Malay.xml
+share/gnome/dasher/alphabet.Malayalam.xml
+share/gnome/dasher/alphabet.Marathi.xml
share/gnome/dasher/alphabet.Moldavian.xml
share/gnome/dasher/alphabet.Ndebele.xml
+share/gnome/dasher/alphabet.Oriya.xml
+share/gnome/dasher/alphabet.Punjabi.xml
share/gnome/dasher/alphabet.Romanian.xml
share/gnome/dasher/alphabet.Sami.xml
share/gnome/dasher/alphabet.ScotsGaelic.xml
share/gnome/dasher/alphabet.Sepedi.xml
share/gnome/dasher/alphabet.Sesotho.xml
+share/gnome/dasher/alphabet.Sinhala.xml
share/gnome/dasher/alphabet.Slovak.xml
share/gnome/dasher/alphabet.Slovenian.xml
share/gnome/dasher/alphabet.Swati.xml
share/gnome/dasher/alphabet.Tajik.xml
+share/gnome/dasher/alphabet.Tamil.xml
+share/gnome/dasher/alphabet.Telugu.xml
share/gnome/dasher/alphabet.Thai.xml
share/gnome/dasher/alphabet.Tsonga.xml
share/gnome/dasher/alphabet.Tswana.xml
@@ -34,12 +50,20 @@ share/gnome/dasher/alphabet.Vietnamese.xml
share/gnome/dasher/alphabet.Xhosa.xml
share/gnome/dasher/alphabet.Yoruba.xml
share/gnome/dasher/alphabet.Zulu.xml
+share/gnome/dasher/alphabet.afrikaans.xml
share/gnome/dasher/alphabet.albanian.xml
+share/gnome/dasher/alphabet.arabic.xml
+share/gnome/dasher/alphabet.bengali.xml
+share/gnome/dasher/alphabet.bopomofo.xml
+share/gnome/dasher/alphabet.catalan.xml
+share/gnome/dasher/alphabet.chinese.xml
+share/gnome/dasher/alphabet.chineseRuby.xml
share/gnome/dasher/alphabet.czech.xml
share/gnome/dasher/alphabet.danish.xml
share/gnome/dasher/alphabet.dtd
share/gnome/dasher/alphabet.dutch.xml
share/gnome/dasher/alphabet.english.xml
+share/gnome/dasher/alphabet.english2.xml
share/gnome/dasher/alphabet.finnish.xml
share/gnome/dasher/alphabet.french.xml
share/gnome/dasher/alphabet.german.xml
@@ -50,33 +74,77 @@ share/gnome/dasher/alphabet.hungarian.xml
share/gnome/dasher/alphabet.hungarianLowerCase.xml
share/gnome/dasher/alphabet.ipa.xml
share/gnome/dasher/alphabet.italian.xml
+share/gnome/dasher/alphabet.klingon.xml
share/gnome/dasher/alphabet.korean.xml
share/gnome/dasher/alphabet.mongolian.xml
+share/gnome/dasher/alphabet.mongolian2.xml
share/gnome/dasher/alphabet.norwegian.xml
+share/gnome/dasher/alphabet.persian.xml
+share/gnome/dasher/alphabet.pinyin.xml
share/gnome/dasher/alphabet.polish.xml
share/gnome/dasher/alphabet.portuguese.xml
share/gnome/dasher/alphabet.russian.xml
share/gnome/dasher/alphabet.spanish.xml
share/gnome/dasher/alphabet.swahili.xml
share/gnome/dasher/alphabet.swedish.xml
+share/gnome/dasher/alphabet.thaana.xml
+share/gnome/dasher/alphabet.venda.xml
share/gnome/dasher/alphabet.welsh.xml
share/gnome/dasher/alphabet.xsl
share/gnome/dasher/colour.dtd
share/gnome/dasher/colour.hiragana.xml
share/gnome/dasher/colour.xml
share/gnome/dasher/dasher.glade
+share/gnome/dasher/training_Afrikaans_ZA.txt
+share/gnome/dasher/training_Assamese_IN.txt
+share/gnome/dasher/training_English_ZA.txt
+share/gnome/dasher/training_Esperanto_XX.txt
+share/gnome/dasher/training_Gujarati_IN.txt
+share/gnome/dasher/training_Hindi_IN.txt
+share/gnome/dasher/training_Japanese_JP.txt
+share/gnome/dasher/training_Kannada_IN.txt
+share/gnome/dasher/training_Kashmiri_IN.txt
+share/gnome/dasher/training_Malayalam_IN.txt
+share/gnome/dasher/training_Marathi_IN.txt
+share/gnome/dasher/training_Ndebele_ZA.txt
+share/gnome/dasher/training_Oriya_IN.txt
+share/gnome/dasher/training_Punjabi_IN.txt
+share/gnome/dasher/training_Punjabi_IPA_IN.txt
+share/gnome/dasher/training_Sepedi_ZA.txt
+share/gnome/dasher/training_Sesotho_ZA.txt
+share/gnome/dasher/training_Sinhala_IN.txt
+share/gnome/dasher/training_Swati_ZA.txt
+share/gnome/dasher/training_Tamil_IN.txt
+share/gnome/dasher/training_Telugu_IN.txt
+share/gnome/dasher/training_Tsonga_ZA.txt
+share/gnome/dasher/training_Tswana_ZA.txt
+share/gnome/dasher/training_Urdu_PK.txt
+share/gnome/dasher/training_Venda_ZA.txt
+share/gnome/dasher/training_Xhosa_ZA.txt
+share/gnome/dasher/training_Zulu_ZA.txt
+share/gnome/dasher/training_albanian_SQ.txt
+share/gnome/dasher/training_bengali_BD.txt
+share/gnome/dasher/training_bengali_bn.txt
share/gnome/dasher/training_czech_CS.txt
+share/gnome/dasher/training_danish_DK.txt
share/gnome/dasher/training_dutch_NL.txt
share/gnome/dasher/training_english_GB.txt
+share/gnome/dasher/training_finnish_FI.txt
share/gnome/dasher/training_french_FR.txt
share/gnome/dasher/training_german_DE.txt
+share/gnome/dasher/training_greek_GR.txt
share/gnome/dasher/training_hebrew_IL.txt
share/gnome/dasher/training_hiragana60_JP.txt
share/gnome/dasher/training_hiragana83_JP.txt
+share/gnome/dasher/training_hungarian_HU.txt
share/gnome/dasher/training_italian_IT.txt
share/gnome/dasher/training_mongolian_MN.txt
+share/gnome/dasher/training_polish_PL.txt
share/gnome/dasher/training_portuguese_BR.txt
share/gnome/dasher/training_russian_RU.txt
+share/gnome/dasher/training_spanish_ES.txt
+share/gnome/dasher/training_swahili_KE.txt
+share/gnome/dasher/training_swedish_SE.txt
share/gnome/dasher/training_welsh_GB.txt
share/gnome/help/dasher/C/dasher.xml
share/gnome/help/dasher/C/figures/figure2.png
@@ -89,12 +157,12 @@ share/gnome/help/dasher/C/figures/prefs5.png
share/gnome/help/dasher/C/version.xml
share/gnome/icons/dasher.png
share/gnome/omf/dasher/dasher-C.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/dasher/dasher-C.omf 2>/dev/null || /usr/bin/true
share/locale/ar/LC_MESSAGES/dasher.mo
share/locale/az/LC_MESSAGES/dasher.mo
share/locale/be/LC_MESSAGES/dasher.mo
share/locale/bg/LC_MESSAGES/dasher.mo
share/locale/bn/LC_MESSAGES/dasher.mo
+share/locale/bs/LC_MESSAGES/dasher.mo
share/locale/ca/LC_MESSAGES/dasher.mo
share/locale/cs/LC_MESSAGES/dasher.mo
share/locale/cy/LC_MESSAGES/dasher.mo
@@ -108,7 +176,9 @@ share/locale/et/LC_MESSAGES/dasher.mo
share/locale/fi/LC_MESSAGES/dasher.mo
share/locale/fr/LC_MESSAGES/dasher.mo
share/locale/ga/LC_MESSAGES/dasher.mo
+share/locale/gu/LC_MESSAGES/dasher.mo
share/locale/he/LC_MESSAGES/dasher.mo
+share/locale/hi/LC_MESSAGES/dasher.mo
share/locale/hr/LC_MESSAGES/dasher.mo
share/locale/hu/LC_MESSAGES/dasher.mo
share/locale/id/LC_MESSAGES/dasher.mo
@@ -116,8 +186,10 @@ share/locale/it/LC_MESSAGES/dasher.mo
share/locale/ja/LC_MESSAGES/dasher.mo
share/locale/ko/LC_MESSAGES/dasher.mo
share/locale/lt/LC_MESSAGES/dasher.mo
+share/locale/mk/LC_MESSAGES/dasher.mo
share/locale/mn/LC_MESSAGES/dasher.mo
share/locale/ms/LC_MESSAGES/dasher.mo
+share/locale/nb/LC_MESSAGES/dasher.mo
share/locale/ne/LC_MESSAGES/dasher.mo
share/locale/nl/LC_MESSAGES/dasher.mo
share/locale/no/LC_MESSAGES/dasher.mo
@@ -132,6 +204,8 @@ share/locale/sq/LC_MESSAGES/dasher.mo
share/locale/sr/LC_MESSAGES/dasher.mo
share/locale/sr@Latn/LC_MESSAGES/dasher.mo
share/locale/sv/LC_MESSAGES/dasher.mo
+share/locale/ta/LC_MESSAGES/dasher.mo
+share/locale/tk/LC_MESSAGES/dasher.mo
share/locale/tr/LC_MESSAGES/dasher.mo
share/locale/uk/LC_MESSAGES/dasher.mo
share/locale/zh_CN/LC_MESSAGES/dasher.mo
@@ -141,4 +215,3 @@ share/locale/zh_TW/LC_MESSAGES/dasher.mo
@dirrm share/gnome/help/dasher/C
@dirrm share/gnome/help/dasher
@dirrm share/gnome/dasher
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/dasher/dasher-C.omf 2>/dev/null || /usr/bin/true