aboutsummaryrefslogtreecommitdiff
path: root/accessibility/gnomespeech
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-30 19:17:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-30 19:17:21 +0000
commit4a5ad7722b02b3005273e6dd80cdc417c351867f (patch)
tree59455439ee25fdfeee140ecff1cee4b184e1e1f4 /accessibility/gnomespeech
parent97a9b49f9e8e167a6965fdb6fc07e167738998ce (diff)
downloadports-4a5ad7722b02b3005273e6dd80cdc417c351867f.tar.gz
ports-4a5ad7722b02b3005273e6dd80cdc417c351867f.zip
Notes
Diffstat (limited to 'accessibility/gnomespeech')
-rw-r--r--accessibility/gnomespeech/Makefile4
-rw-r--r--accessibility/gnomespeech/distinfo4
-rw-r--r--accessibility/gnomespeech/files/patch-ltmain.sh51
3 files changed, 4 insertions, 55 deletions
diff --git a/accessibility/gnomespeech/Makefile b/accessibility/gnomespeech/Makefile
index 7d50fa970e2a..3b2544516125 100644
--- a/accessibility/gnomespeech/Makefile
+++ b/accessibility/gnomespeech/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnomespeech
-PORTVERSION= 0.3.3
+PORTVERSION= 0.3.5
CATEGORIES= accessibility audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-speech/0.3
@@ -19,7 +19,7 @@ COMMENT= GNOME text-to-speech API
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack libbonobo
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
diff --git a/accessibility/gnomespeech/distinfo b/accessibility/gnomespeech/distinfo
index c8f8ee05bfcd..c1481e4d4f25 100644
--- a/accessibility/gnomespeech/distinfo
+++ b/accessibility/gnomespeech/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-speech-0.3.3.tar.bz2) = 8ee8cb9196da9971ff7d497e88f4eadd
-SIZE (gnome2/gnome-speech-0.3.3.tar.bz2) = 253310
+MD5 (gnome2/gnome-speech-0.3.5.tar.bz2) = 34382d0b33146b1f8fc5239895471369
+SIZE (gnome2/gnome-speech-0.3.5.tar.bz2) = 255271
diff --git a/accessibility/gnomespeech/files/patch-ltmain.sh b/accessibility/gnomespeech/files/patch-ltmain.sh
index be26a38ade1b..e69de29bb2d1 100644
--- a/accessibility/gnomespeech/files/patch-ltmain.sh
+++ b/accessibility/gnomespeech/files/patch-ltmain.sh
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Fri May 2 16:51:22 2003
-+++ ltmain.sh Tue May 20 15:31:37 2003
-@@ -1277,7 +1277,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1287,8 +1287,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2997,6 +3005,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5425,10 +5436,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"