aboutsummaryrefslogtreecommitdiff
path: root/accessibility/orca
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-05-05 19:22:06 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-05-05 19:22:06 +0000
commitad74f964cbf13a794665e7a3d876b93951bfc028 (patch)
treedb3ff91795ddb39740362eeee752e71d506d73b8 /accessibility/orca
parented7aae3ee13a622842a91ae5a26c14b0425b64f7 (diff)
downloadports-ad74f964cbf13a794665e7a3d876b93951bfc028.tar.gz
ports-ad74f964cbf13a794665e7a3d876b93951bfc028.zip
Notes
Diffstat (limited to 'accessibility/orca')
-rw-r--r--accessibility/orca/Makefile2
-rw-r--r--accessibility/orca/files/patch-src_orca_orca.in37
2 files changed, 33 insertions, 6 deletions
diff --git a/accessibility/orca/Makefile b/accessibility/orca/Makefile
index 94d49f3ddcfe..aeffa52143b9 100644
--- a/accessibility/orca/Makefile
+++ b/accessibility/orca/Makefile
@@ -8,6 +8,7 @@
PORTNAME= orca
PORTVERSION= 2.22.1
+PORTREVISION= 1
CATEGORIES= accessibility gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,7 +17,6 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Scriptable screen reader
LIB_DEPENDS= gnome-mag.2:${PORTSDIR}/accessibility/gnome-mag
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
LATEST_LINK= gnome-orca
diff --git a/accessibility/orca/files/patch-src_orca_orca.in b/accessibility/orca/files/patch-src_orca_orca.in
index 1aa834d5d041..45218dd7615e 100644
--- a/accessibility/orca/files/patch-src_orca_orca.in
+++ b/accessibility/orca/files/patch-src_orca_orca.in
@@ -1,8 +1,8 @@
---- src/orca/orca.in.orig 2007-11-08 11:02:26.000000000 -0500
-+++ src/orca/orca.in 2007-11-15 15:43:24.000000000 -0500
+--- src/orca/orca.in.orig 2008-05-01 16:52:27.000000000 -0500
++++ src/orca/orca.in 2008-05-01 16:57:15.000000000 -0500
@@ -1,4 +1,4 @@
-#!/bin/bash
-+#!/usr/local/bin/bash
++#!/bin/sh
#
# Orca
#
@@ -11,11 +11,20 @@
# Set the user's $PATH for this script.
#
-export PATH="${PATH}:/usr/ccs/bin:/usr/bin:/usr/sbin:/bin:/usr/sfw/bin:/usr/openwin/bin:/usr/X11R6/bin"
-+export PATH="${PATH}:/usr/ccs/bin:/usr/bin:/usr/sbin:/bin:/usr/sfw/bin:/usr/openwin/bin:/usr/local/bin:/usr/X11R6/bin"
++export PATH="${PATH}:/usr/bin:/usr/sbin:/bin:/usr/local/bin"
# If you set RUNONCE to "true", then this will just run Orca once and quit.
#
-@@ -145,7 +145,7 @@ watchdog()
+@@ -74,7 +74,7 @@
+ cleanup()
+ {
+ USERID=`id | cut -f2 -d= | cut -f1 -d\(`
+- PIDS=`ps -eo pid,ruid,args | grep $USERID | egrep "orca[.]orca|synthesis-driver|festival [-][-]server" | grep -v grep | awk '{ print $1 }'`
++ PIDS=`ps -exo pid,ruid,args | grep $USERID | egrep "orca[.]orca|synthesis-driver|festival [-][-]server" | grep -v grep | awk '{ print $1 }'`
+
+ IFS='
+ '
+@@ -145,7 +145,7 @@
do
sleep 5
USERID=`id | cut -f2 -d= | cut -f1 -d\(`
@@ -24,3 +33,21 @@
if [ "x$PID" = "x" ]
then
+@@ -258,7 +258,7 @@
+ then
+ main
+ else
+- if [ `grep -c "\-q" <<< $ARGS` -gt 0 ]
++ if [ `echo $ARGS | grep -c "\-q"` -gt 0 ]
+ then
+ cleanup
+ else
+@@ -270,7 +270,7 @@
+ # erroneously types an illegal command line argument, the
+ # help text is emitted and the other orca is not killed.
+ #
+- if [ `egrep -c "\-s|\-g|\-t|\-n|\-u|\-e|\-d" <<< $ARGS` -eq 0 ]
++ if [ `echo $ARGS | egrep -c "\-s|\-g|\-t|\-n|\-u|\-e|\-d"` -eq 0 ]
+ then
+ runOrca "NO_CLEANUP"
+ else