aboutsummaryrefslogtreecommitdiff
path: root/accessibility/redshift/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-11-25 04:12:51 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-11-25 04:12:51 +0000
commit01dc94c1c1c1c798f4fb52bbd859bf9cb9a6d126 (patch)
tree52a1d4f80158154e90f915ba8af47907ab125256 /accessibility/redshift/Makefile
parent98fa194a83186868773644a5c7661827a5e1ece4 (diff)
downloadports-01dc94c1c1c1c798f4fb52bbd859bf9cb9a6d126.tar.gz
ports-01dc94c1c1c1c798f4fb52bbd859bf9cb9a6d126.zip
Notes
Diffstat (limited to 'accessibility/redshift/Makefile')
-rw-r--r--accessibility/redshift/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/accessibility/redshift/Makefile b/accessibility/redshift/Makefile
new file mode 100644
index 000000000000..5cf3d4b1fe15
--- /dev/null
+++ b/accessibility/redshift/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: redshift
+# Date created: Wed Nov 24 12:35:17 CST 2010
+# Whom: Mark Felder <feld@feld.me>
+#
+# $FreeBSD$
+#
+
+PORTNAME= redshift
+PORTVERSION= 1.6
+CATEGORIES= accessibility
+MASTER_SITES= http://launchpad.net/redshift/trunk/${PORTVERSION}/+download/
+
+MAINTAINER= feld@feld.me
+COMMENT= Adjusts the color temperature of your screen
+
+FETCH_ARGS= "-pRr"
+USE_GMAKE= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+MAN1= redshift.1
+MANCOMPRESSED= no
+
+CONFIGURE_ARGS+=--disable-wingdi --disable-gnome-clock --disable-gui
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
+OPTIONS= GUI "Tray icon & location via Gnome clock" off \
+ RANDR "Support RANDR for changing colors" on \
+ VIDMODE "Support VIDMODE for changing colors (NVIDIA)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_RANDR)
+CONFIGURE_ARGS+=--enable-randr
+USE_XORG= xrandr
+.else
+CONFIGURE_ARGS+=--disable-randr
+.endif
+
+.if defined(WITH_VIDMODE)
+CONFIGURE_ARGS+=--enable-vidmode
+.else
+CONFIGURE_ARGS+=--disable-vidmode
+.endif
+
+.if defined(WITH_GUI)
+CONFIGURE_ARGS+=--enable-gui --enable-gnome-clock
+RUN_DEPENDS+= py-gtk2:${PORTSDIR}/x11-toolkits/py-gtk2 \
+ py-xdg:${PORTSDIR}/devel/py-xdg
+PLIST_SUB+= GUI=""
+.else
+CONFIGURE_ARGS+=--disable-gui --disable-gnome-clock
+PLIST_SUB+= GUI="@comment "
+.endif
+
+.include <bsd.port.mk>