aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /accessibility
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/Makefile3
-rw-r--r--accessibility/accerciser/Makefile2
-rw-r--r--accessibility/caribou/Makefile2
-rw-r--r--accessibility/orca/Makefile18
-rw-r--r--accessibility/py-atspi/Makefile10
-rw-r--r--accessibility/py-atspi/pkg-plist-py3 (renamed from accessibility/py3-atspi/pkg-plist)0
-rw-r--r--accessibility/py-speech-dispatcher/Makefile (renamed from accessibility/py3-speech-dispatcher/Makefile)0
-rw-r--r--accessibility/py-speech-dispatcher/pkg-plist (renamed from accessibility/py3-speech-dispatcher/pkg-plist)0
-rw-r--r--accessibility/py3-atspi/Makefile27
-rw-r--r--accessibility/py3-atspi/distinfo3
-rw-r--r--accessibility/py3-atspi/pkg-descr8
-rw-r--r--accessibility/redshift/Makefile6
-rw-r--r--accessibility/speech-dispatcher/Makefile3
13 files changed, 26 insertions, 56 deletions
diff --git a/accessibility/Makefile b/accessibility/Makefile
index a1a5bd348fdb..ba82967c6a84 100644
--- a/accessibility/Makefile
+++ b/accessibility/Makefile
@@ -23,8 +23,7 @@
SUBDIR += orca
SUBDIR += py-atspi
SUBDIR += py-papi
- SUBDIR += py3-atspi
- SUBDIR += py3-speech-dispatcher
+ SUBDIR += py-speech-dispatcher
SUBDIR += qt4-accessible
SUBDIR += redshift
SUBDIR += rubygem-atk
diff --git a/accessibility/accerciser/Makefile b/accessibility/accerciser/Makefile
index 71b78d5ffce1..26c5c2a21574 100644
--- a/accessibility/accerciser/Makefile
+++ b/accessibility/accerciser/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= gsettings-desktop-schemas>=3.2.0:devel/gsettings-desktop-schemas \
at-spi2-core>=2.1.5:accessibility/at-spi2-core
NO_ARCH= yes
-USES= gettext gmake pkgconfig python:3 shebangfix tar:xz
+USES= gettext gmake pkgconfig python:3.4+ shebangfix tar:xz
USE_GNOME= gtk30 intlhack py3gobject3
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/accessibility/caribou/Makefile b/accessibility/caribou/Makefile
index 665ece56ed7c..89a1cf226562 100644
--- a/accessibility/caribou/Makefile
+++ b/accessibility/caribou/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libclutter-glx-1.0.so:graphics/clutter \
libgee-0.8.so:devel/libgee \
libxklavier.so:x11/libxklavier
-RUN_DEPENDS= py2?-atspi>=2.1.91:accessibility/py-atspi
+RUN_DEPENDS= py2?-atspi>=2.1.91:accessibility/py-atspi@${PY_FLAVOR}
USES= gettext gmake gnome libtool pathfix pkgconfig python:2 \
shebangfix tar:xz
diff --git a/accessibility/orca/Makefile b/accessibility/orca/Makefile
index d817d3a7a600..eadbc07578d5 100644
--- a/accessibility/orca/Makefile
+++ b/accessibility/orca/Makefile
@@ -10,16 +10,16 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Scriptable screen reader
-BUILD_DEPENDS= py3?-dbus>=0:devel/py3-dbus \
- py3?-xdg>=0:devel/py3-xdg \
- py3?-cairo>=0:graphics/py3-cairo \
+BUILD_DEPENDS= py3?-dbus>=0:devel/py-dbus@${PY_FLAVOR} \
+ py3?-xdg>=0:devel/py-xdg@${PY_FLAVOR} \
+ py3?-cairo>=0:graphics/py-cairo@${PY_FLAVOR} \
itstool:textproc/itstool
LIB_DEPENDS= libatspi.so:accessibility/at-spi2-core
-RUN_DEPENDS= py3?-dbus>=0:devel/py3-dbus \
- py3?-speech-dispatcher>=0:accessibility/py3-speech-dispatcher \
- py3?-atspi>=0:accessibility/py3-atspi \
- py3?-xdg>=0:devel/py3-xdg \
- py3?-cairo>=0:graphics/py3-cairo
+RUN_DEPENDS= py3?-dbus>=0:devel/py-dbus@${PY_FLAVOR} \
+ py3?-speech-dispatcher>=0:accessibility/py-speech-dispatcher@${PY_FLAVOR} \
+ py3?-atspi>=0:accessibility/py-atspi@${PY_FLAVOR} \
+ py3?-xdg>=0:devel/py-xdg@${PY_FLAVOR} \
+ py3?-cairo>=0:graphics/py-cairo@${PY_FLAVOR}
# conflict with py*-json-py because orca uses the json from python itself
# and py*-json-py shadows this.
@@ -27,7 +27,7 @@ CONFLICTS= py*-json-py-[0-9]*
PORTSCOUT= limitw:1,even
NO_ARCH= yes
-USES= gettext gmake gnome pathfix pkgconfig python:3 tar:xz
+USES= gettext gmake gnome pathfix pkgconfig python:3.4+ tar:xz
USE_GNOME= gtk30 py3gobject3 intlhack
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/accessibility/py-atspi/Makefile b/accessibility/py-atspi/Makefile
index fa5f938f0403..bef8fe3ed2cc 100644
--- a/accessibility/py-atspi/Makefile
+++ b/accessibility/py-atspi/Makefile
@@ -19,8 +19,16 @@ RUN_DEPENDS= ${LOCALBASE}/libexec/at-spi2-registryd:accessibility/at-spi2-core
CONFLICTS= at-spi-1.[0-9]*
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome localbase pathfix pkgconfig python:2 tar:xz
+USES= gettext gmake gnome localbase pathfix pkgconfig python tar:xz
+USE_PYTHON= flavors
+.if ${FLAVOR:Upy27:Mpy2*}
USE_GNOME= intlhack pygobject3
+.else
+USE_GNOME= intlhack py3gobject3
+.endif
+py34_PLIST= ${.CURDIR}/pkg-plist-py3
+py35_PLIST= ${.CURDIR}/pkg-plist-py3
+py36_PLIST= ${.CURDIR}/pkg-plist-py3
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/accessibility/py3-atspi/pkg-plist b/accessibility/py-atspi/pkg-plist-py3
index 71dfa77a8eec..71dfa77a8eec 100644
--- a/accessibility/py3-atspi/pkg-plist
+++ b/accessibility/py-atspi/pkg-plist-py3
diff --git a/accessibility/py3-speech-dispatcher/Makefile b/accessibility/py-speech-dispatcher/Makefile
index ea846a052a2f..ea846a052a2f 100644
--- a/accessibility/py3-speech-dispatcher/Makefile
+++ b/accessibility/py-speech-dispatcher/Makefile
diff --git a/accessibility/py3-speech-dispatcher/pkg-plist b/accessibility/py-speech-dispatcher/pkg-plist
index 303d9074311f..303d9074311f 100644
--- a/accessibility/py3-speech-dispatcher/pkg-plist
+++ b/accessibility/py-speech-dispatcher/pkg-plist
diff --git a/accessibility/py3-atspi/Makefile b/accessibility/py3-atspi/Makefile
deleted file mode 100644
index 0ec6a6f3220c..000000000000
--- a/accessibility/py3-atspi/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= atspi
-PORTVERSION= 2.24.0
-CATEGORIES= accessibility x11-toolkits python
-MASTER_SITES= GNOME/sources/pyatspi/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= pyatspi-${PORTVERSION}
-DIST_SUBDIR= gnome3
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= Python3 API for the D-BUS based SPI framework
-
-LICENSE= LGPL20
-
-RUN_DEPENDS= ${LOCALBASE}/libexec/at-spi2-registryd:accessibility/at-spi2-core
-
-CONFLICTS= at-spi-1.[0-9]*
-PORTSCOUT= limitw:1,even
-
-NO_ARCH= yes
-USES= gettext gmake gnome localbase pathfix pkgconfig python:3 tar:xz
-USE_GNOME= intlhack py3gobject3
-GNU_CONFIGURE= yes
-
-.include <bsd.port.mk>
diff --git a/accessibility/py3-atspi/distinfo b/accessibility/py3-atspi/distinfo
deleted file mode 100644
index 9d717a35f5af..000000000000
--- a/accessibility/py3-atspi/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1491080637
-SHA256 (gnome3/pyatspi-2.24.0.tar.xz) = e7ef47a5d387fdc64a01722ef2bcced54c4d6b225fbe34867189e1f88ff0a692
-SIZE (gnome3/pyatspi-2.24.0.tar.xz) = 298228
diff --git a/accessibility/py3-atspi/pkg-descr b/accessibility/py3-atspi/pkg-descr
deleted file mode 100644
index 151f94c993e2..000000000000
--- a/accessibility/py3-atspi/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-This is the Gnome Accessibility Project's Assistive Technology
-Service Provider Interface. It allows accessibility applications
-and assistive technologies to announce their respective existence
-to each other.
-
-This port is the Python API to interface with the D-BUS based SPI framework.
-
-WWW: http://www.linuxfoundation.org/en/AT-SPI_on_D-Bus
diff --git a/accessibility/redshift/Makefile b/accessibility/redshift/Makefile
index 7b35b3a5650f..79905e36b3d4 100644
--- a/accessibility/redshift/Makefile
+++ b/accessibility/redshift/Makefile
@@ -42,10 +42,10 @@ RANDR_CONFIGURE_ENABLE= randr
VIDMODE_USE= XORG=xxf86vm
VIDMODE_CONFIGURE_ENABLE= vidmode
-GUI_USES= python
+GUI_USES= python:2.7
GUI_CONFIGURE_ENABLE= gui
-GUI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>0:x11-toolkits/py-gtk2 \
- ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg
+GUI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>0:x11-toolkits/py-gtk2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg@${PY_FLAVOR}
GNOME_CONFIGURE_ENABLE= gnome-clock
GNOME_USE= GNOME=glib20,gconf2
diff --git a/accessibility/speech-dispatcher/Makefile b/accessibility/speech-dispatcher/Makefile
index 47e84916fa30..44cd856160c2 100644
--- a/accessibility/speech-dispatcher/Makefile
+++ b/accessibility/speech-dispatcher/Makefile
@@ -92,8 +92,9 @@ PORTSCOUT= ignore:1
NO_ARCH= yes
USES+= python:3.3+
+USE_PYTHON= flavors
LIB_DEPENDS+= libspeechd.so:accessibility/speech-dispatcher
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/xdg/__init__.py:devel/py3-xdg
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/xdg/__init__.py:devel/py-xdg@${FLAVOR}
.endif