aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-03 20:01:14 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-03 20:01:14 +0000
commit654093c5478a0b3348d498344a78e1553880196b (patch)
treeeb905eda0f57c2babff62ba010ad619e99743ca6 /accessibility
parentf17cf8c9786b400503bd400ffe92b1522d86e8e2 (diff)
downloadports-654093c5478a0b3348d498344a78e1553880196b.tar.gz
ports-654093c5478a0b3348d498344a78e1553880196b.zip
Notes
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/py-papi/Makefile4
-rw-r--r--accessibility/redshift/Makefile57
2 files changed, 15 insertions, 46 deletions
diff --git a/accessibility/py-papi/Makefile b/accessibility/py-papi/Makefile
index 828f223d7564..62c427db8874 100644
--- a/accessibility/py-papi/Makefile
+++ b/accessibility/py-papi/Makefile
@@ -21,16 +21,12 @@ EXAMPLES= atkaction.py atkapplication.py atkcapi.c atktext.py atkvalue.py \
OPTIONS_DEFINE= EXAMPLES
-.include <bsd.port.options.mk>
-
post-patch:
${REINPLACE_CMD} -i "" -e 's|: docfiles|: []|g' ${WRKSRC}/setup.py
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
@${INSTALL} -d ${STAGEDIR}${EXAMPLESDIR}/
@cd ${WRKSRC}/doc/examples && \
${INSTALL_DATA} ${EXAMPLES} ${STAGEDIR}${EXAMPLESDIR}/
-.endif
.include <bsd.port.mk>
diff --git a/accessibility/redshift/Makefile b/accessibility/redshift/Makefile
index 872eb6d8eb1e..8c53737b6f19 100644
--- a/accessibility/redshift/Makefile
+++ b/accessibility/redshift/Makefile
@@ -17,57 +17,30 @@ INSTALLS_ICONS= yes
CONFIGURE_ARGS+= --disable-wingdi
OPTIONS_DEFINE= GNOME GUI NLS RANDR VIDMODE
-OPTIONS_DEFAULT= RANDR
+OPTIONS_DEFAULT=RANDR
+OPTIONS_SUB= yes
GNOME_DESC= GNOME clock support
GUI_DESC= Tray icon
RANDR_DESC= Support RANDR for changing colors
VIDMODE_DESC= Support VIDMODE for changing colors (NVIDIA)
-.include <bsd.port.options.mk>
+NLS_USES= gettext iconv
+NLS_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG} \
+ --with-libintl-prefix=${LOCALBASE}
+NLS_CONFIGURE_OFF= --disable-nls
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext iconv
-CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG} \
- --with-libintl-prefix=${LOCALBASE}
-PLIST_SUB= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
+RANDR_USE= XORG=xrandr
+RANDR_CONFIGURE_ENABLE= randr
-.if ${PORT_OPTIONS:MRANDR}
-CONFIGURE_ARGS+=--enable-randr
-USE_XORG= xrandr
-.else
-CONFIGURE_ARGS+=--disable-randr
-.endif
+VIDMODE_CONFIGURE_ENABLE= vidmode
-.if ${PORT_OPTIONS:MVIDMODE}
-CONFIGURE_ARGS+=--enable-vidmode
-.else
-CONFIGURE_ARGS+=--disable-vidmode
-.endif
+GUI_USE= PYTHON=yes
+GUI_CONFIGURE_ENABLE= gui
+GUI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>0:${PORTSDIR}/x11-toolkits/py-gtk2 \
+ ${PYTHON_PKGNAMEPREFIX}xdg>0:${PORTSDIR}/devel/py-xdg
-.if ${PORT_OPTIONS:MGUI}
-USE_PYTHON= yes
-CONFIGURE_ARGS+=--enable-gui
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>0:${PORTSDIR}/x11-toolkits/py-gtk2 \
- ${PYTHON_PKGNAMEPREFIX}xdg>0:${PORTSDIR}/devel/py-xdg
-PLIST_SUB+= GUI=""
-.else
-CONFIGURE_ARGS+=--disable-gui
-PLIST_SUB+= GUI="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MGNOME}
-CONFIGURE_ARGS+=--enable-gnome-clock
-BUILD_DEPENDS+= glib>0:${PORTSDIR}/devel/glib20 \
- gconf2>0:${PORTSDIR}/devel/gconf2
-RUN_DEPENDS+= glib>0:${PORTSDIR}/devel/glib20 \
- gconf2>0:${PORTSDIR}/devel/gconf2
-.else
-CONFIGURE_ARGS+=--disable-gnome-clock
-.endif
+GNOME_CONFIGURE_ENABLE= gnome-clock
+GNOME_USE= GNOME=glib20,gconf2
.include <bsd.port.mk>