aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /accessibility
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/jovie-kde4/Makefile4
-rw-r--r--accessibility/kaccessible-kde4/Makefile4
-rw-r--r--accessibility/kmag-kde4/Makefile4
-rw-r--r--accessibility/kmag/Makefile4
-rw-r--r--accessibility/kmousetool-kde4/Makefile4
-rw-r--r--accessibility/kmousetool/Makefile4
-rw-r--r--accessibility/kmouth-kde4/Makefile4
-rw-r--r--accessibility/kmouth/Makefile4
-rw-r--r--accessibility/qt4-accessible/Makefile4
-rw-r--r--accessibility/qt5-speech/Makefile5
10 files changed, 20 insertions, 21 deletions
diff --git a/accessibility/jovie-kde4/Makefile b/accessibility/jovie-kde4/Makefile
index a8e1429ccd3a..a6d6c7eb1aec 100644
--- a/accessibility/jovie-kde4/Makefile
+++ b/accessibility/jovie-kde4/Makefile
@@ -10,9 +10,9 @@ COMMENT= KDE text-to-speech system
LIB_DEPENDS= libspeechd.so:accessibility/speech-dispatcher
-USES= cmake:outsource kde:4 tar:xz
+USES= cmake:outsource kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
-USE_QT4= xml qmake_build moc_build uic_build rcc_build
+USE_QT= xml qmake_build moc_build uic_build rcc_build
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/accessibility/kaccessible-kde4/Makefile b/accessibility/kaccessible-kde4/Makefile
index 197c6f0a9975..2f7eabed3639 100644
--- a/accessibility/kaccessible-kde4/Makefile
+++ b/accessibility/kaccessible-kde4/Makefile
@@ -10,9 +10,9 @@ COMMENT= Accessibility services for KDE
LIB_DEPENDS= libspeechd.so:accessibility/speech-dispatcher
-USES= cmake:outsource kde:4 tar:xz
+USES= cmake:outsource kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
-USE_QT4= corelib dbus gui xml \
+USE_QT= corelib dbus gui xml \
qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/accessibility/kmag-kde4/Makefile b/accessibility/kmag-kde4/Makefile
index a2ac4ba42ac1..6ccdf20c424b 100644
--- a/accessibility/kmag-kde4/Makefile
+++ b/accessibility/kmag-kde4/Makefile
@@ -8,9 +8,9 @@ CATEGORIES= accessibility kde kde-kde4
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Screen magnifier
-USES= cmake:outsource kde:4 tar:xz
+USES= cmake:outsource kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
-USE_QT4= qmake_build moc_build rcc_build uic_build
+USE_QT= qmake_build moc_build rcc_build uic_build
# Somebody has to create port for libkdeaccessibilityclient first
CMAKE_ARGS+= -DWITH_QAccessibilityClient=off
diff --git a/accessibility/kmag/Makefile b/accessibility/kmag/Makefile
index e2cacf1cc376..3dc669be3dd2 100644
--- a/accessibility/kmag/Makefile
+++ b/accessibility/kmag/Makefile
@@ -10,10 +10,10 @@ COMMENT= KDE Screen magnifier
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource gettext kde:5 tar:xz
+USES= cmake:outsource gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons ecm \
i18n kio service widgetsaddons xmlgui
-USE_QT5= core dbus gui printsupport widgets xml \
+USE_QT= core dbus gui printsupport widgets xml \
buildtools_build qmake_build
.include <bsd.port.mk>
diff --git a/accessibility/kmousetool-kde4/Makefile b/accessibility/kmousetool-kde4/Makefile
index 640ddd6ace93..8d5ffb90139d 100644
--- a/accessibility/kmousetool-kde4/Makefile
+++ b/accessibility/kmousetool-kde4/Makefile
@@ -8,9 +8,9 @@ CATEGORIES= accessibility kde kde-kde4
MAINTAINER= kde@FreeBSD.org
COMMENT= Automatic mouse click tool for KDE
-USES= cmake:outsource kde:4 tar:xz
+USES= cmake:outsource kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
-USE_QT4= qmake_build moc_build rcc_build uic_build
+USE_QT= qmake_build moc_build rcc_build uic_build
USE_XORG= xtst
.include <bsd.port.mk>
diff --git a/accessibility/kmousetool/Makefile b/accessibility/kmousetool/Makefile
index aee2d552442f..a451b0bb3cb5 100644
--- a/accessibility/kmousetool/Makefile
+++ b/accessibility/kmousetool/Makefile
@@ -11,10 +11,10 @@ COMMENT= Automatic mouse click tool for KDE
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource gettext kde:5 tar:xz
+USES= cmake:outsource gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons dbusaddons \
ecm i18n iconthemes notifications widgetsaddons xmlgui
-USE_QT5= core dbus gui phonon4 widgets xml \
+USE_QT= core dbus gui phonon4 widgets xml \
buildtools_build qmake_build
USE_XORG= ice sm x11 xext xtst
diff --git a/accessibility/kmouth-kde4/Makefile b/accessibility/kmouth-kde4/Makefile
index 74bfb286be43..f52b1233ef21 100644
--- a/accessibility/kmouth-kde4/Makefile
+++ b/accessibility/kmouth-kde4/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= accessibility kde kde-kde4
MAINTAINER= kde@FreeBSD.org
COMMENT= Speech synthesizer frontend for KDE
-USES= cmake:outsource kde:4 tar:xz
+USES= cmake:outsource kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
-USE_QT4= qmake_build moc_build rcc_build uic_build
+USE_QT= qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/accessibility/kmouth/Makefile b/accessibility/kmouth/Makefile
index e9fd68e97b4b..dce38eb03a49 100644
--- a/accessibility/kmouth/Makefile
+++ b/accessibility/kmouth/Makefile
@@ -10,10 +10,10 @@ COMMENT= Speech synthesizer frontend for KDE
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource gettext kde:5 tar:xz
+USES= cmake:outsource gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
ecm i18n jobwidgets kio service widgetsaddons xmlgui
-USE_QT5= core dbus gui network printsupport speech widgets xml \
+USE_QT= core dbus gui network printsupport speech widgets xml \
buildtools_build qmake_build
.include <bsd.port.mk>
diff --git a/accessibility/qt4-accessible/Makefile b/accessibility/qt4-accessible/Makefile
index b82e3b04a82e..50d47c092901 100644
--- a/accessibility/qt4-accessible/Makefile
+++ b/accessibility/qt4-accessible/Makefile
@@ -10,8 +10,8 @@ PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt accessibility widgets
-USE_QT4= qmake_build moc_build qt3support corelib gui network sql xml
-QT_DIST= yes
+USES= qmake:no_env qt-dist:4
+USE_QT= moc_build qt3support corelib gui network sql xml
USE_CXXSTD= gnu++98
HAS_CONFIGURE= yes
diff --git a/accessibility/qt5-speech/Makefile b/accessibility/qt5-speech/Makefile
index a3c1f30444c3..22bf69b4fe70 100644
--- a/accessibility/qt5-speech/Makefile
+++ b/accessibility/qt5-speech/Makefile
@@ -10,8 +10,7 @@ COMMENT= Accessibilty features for Qt5
LIB_DEPENDS= libspeechd.so:accessibility/speech-dispatcher
-USES= pkgconfig qmake:outsource
-USE_QT5= core gui buildtools_build qmake_build
-QT_DIST= ${PORTNAME}
+USES= pkgconfig qmake:outsource qt-dist:5,speech
+USE_QT= core gui buildtools_build qmake_build
.include <bsd.port.mk>