aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 06:26:31 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 06:26:31 +0000
commit6ee4f3c0edb78d03dd3593708882d63a840d5fbd (patch)
treedd2960674890c75b92567e09d64953d38bf531fd /accessibility
parentc03bfbe46d862034379cd278fe40e74125bfd355 (diff)
downloadports-6ee4f3c0edb78d03dd3593708882d63a840d5fbd.tar.gz
ports-6ee4f3c0edb78d03dd3593708882d63a840d5fbd.zip
Notes
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/at-spi2-atk/Makefile4
-rw-r--r--accessibility/at-spi2-core/Makefile4
-rw-r--r--accessibility/atk/Makefile4
-rw-r--r--accessibility/atkmm/Makefile4
-rw-r--r--accessibility/py-papi/Makefile8
5 files changed, 10 insertions, 14 deletions
diff --git a/accessibility/at-spi2-atk/Makefile b/accessibility/at-spi2-atk/Makefile
index 3bd292f72607..ca984131a732 100644
--- a/accessibility/at-spi2-atk/Makefile
+++ b/accessibility/at-spi2-atk/Makefile
@@ -19,10 +19,10 @@ RUN_DEPENDS= at-spi2-core>=2.1.4:${PORTSDIR}/accessibility/at-spi2-core
PORTSCOUT= limitw:1,even
+USES= pkgconfig pathfix
USE_XZ= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomehier intlhack glib20 atk
-USE_PKGCONFIG= build
+USE_GNOME= gnomehier intlhack glib20 atk
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/accessibility/at-spi2-core/Makefile b/accessibility/at-spi2-core/Makefile
index d58997e9082b..20f733912997 100644
--- a/accessibility/at-spi2-core/Makefile
+++ b/accessibility/at-spi2-core/Makefile
@@ -18,11 +18,11 @@ LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
PORTSCOUT= limitw:1,even
+USES= pathfix pkgconfig
USE_XZ= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomehier glib20 intlhack
-USE_PKGCONFIG= build
+USE_GNOME= gnomehier glib20 intlhack
USE_XORG= x11 xi xtst xext
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/accessibility/atk/Makefile b/accessibility/atk/Makefile
index bdecb6bfa26f..10a0b104c5a7 100644
--- a/accessibility/atk/Makefile
+++ b/accessibility/atk/Makefile
@@ -18,12 +18,12 @@ USE_XZ= yes
BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+USES= pathfix pkgconfig
USE_GETTEXT= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehier gnomehack glib20 ltverhack referencehack
-USE_PKGCONFIG= build
+USE_GNOME= gnomehier glib20 ltverhack referencehack
CONFIGURE_ARGS= --enable-static \
--with-html-dir=${PREFIX}/share/doc
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/accessibility/atkmm/Makefile b/accessibility/atkmm/Makefile
index 0ee57c149d40..a6f0db8a03c4 100644
--- a/accessibility/atkmm/Makefile
+++ b/accessibility/atkmm/Makefile
@@ -10,12 +10,12 @@ MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= C++ wrapper for ATK API library
+USES= pathfix pkgconfig
USE_XZ= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-USE_GNOME= gnomehack atk glibmm
-USE_PKGCONFIG= build
+USE_GNOME= atk glibmm
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/accessibility/py-papi/Makefile b/accessibility/py-papi/Makefile
index 4032c768ce1b..700a9f780847 100644
--- a/accessibility/py-papi/Makefile
+++ b/accessibility/py-papi/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-papi
-# Date created: 2006-12-19
-# Whom: Marcus von Appen
-#
+# Created by: Marcus von Appen
# $FreeBSD$
-#
PORTNAME= papi
PORTVERSION= 0.0.9
@@ -14,8 +10,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= mva@FreeBSD.org
COMMENT= ATK accessibility wrapper for python
+USES= pkgconfig
USE_GNOME= atk
-USE_PKGCONFIG= build
USE_PYTHON= yes
USE_PYDISTUTILS=yes